aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu.inc')
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 6a744c3e34..c3f73d1ec5 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -3,9 +3,10 @@ HOMEPAGE = "http://qemu.org"
LICENSE = "GPLv2 & LGPLv2.1"
DEPENDS = "glib-2.0 zlib pixman"
RDEPENDS_${PN}_class-target += "bash python"
+RDEPENDS_${PN}-ptest = "bash make"
require qemu-targets.inc
-inherit autotools
+inherit autotools ptest
BBCLASSEXTEND = "native nativesdk"
PR = "r1"
@@ -18,6 +19,8 @@ SRC_URI = "\
file://disable-grabs.patch \
file://exclude-some-arm-EABI-obsolete-syscalls.patch \
file://wacom.patch \
+ file://add-ptest-in-makefile.patch \
+ file://run-ptest \
"
SRC_URI_append_class-native = "\
@@ -54,6 +57,17 @@ do_configure() {
test ! -e ${S}/target-i386/beginend_funcs.sh || chmod a+x ${S}/target-i386/beginend_funcs.sh
}
+do_compile_ptest() {
+ make buildtest-TESTS
+}
+
+do_install_ptest() {
+ cp -rL ${B}/tests ${D}${PTEST_PATH}
+ find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
+
+ cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests
+}
+
do_install () {
export STRIP="true"
autotools_do_install