aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux/files/no-strip.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/syslinux/files/no-strip.patch')
-rw-r--r--meta/recipes-devtools/syslinux/files/no-strip.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/syslinux/files/no-strip.patch b/meta/recipes-devtools/syslinux/files/no-strip.patch
new file mode 100644
index 0000000000..775851a75d
--- /dev/null
+++ b/meta/recipes-devtools/syslinux/files/no-strip.patch
@@ -0,0 +1,31 @@
+Disable stripping of binaries
+
+We don't want to strip these as this is handled separately at package
+time.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+--- syslinux-4.03.orig/mtools/Makefile
++++ syslinux-4.03/mtools/Makefile
+@@ -4,7 +4,7 @@ include $(topdir)/MCONFIG
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libfat -I../libinstaller
+ CFLAGS = $(GCCWARN) -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+-LDFLAGS = -s
++LDFLAGS =
+
+ SRCS = syslinux.c \
+ ../libinstaller/fat.c \
+--- syslinux-4.03.orig/utils/Makefile
++++ syslinux-4.03/utils/Makefile
+@@ -18,7 +18,7 @@ topdir = ..
+ include $(topdir)/MCONFIG
+
+ CFLAGS = $(GCCWARN) -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+-LDFLAGS = -O2 -s
++LDFLAGS = -O2
+
+ TARGETS = mkdiskimage isohybrid gethostip memdiskfind
+ TARGETS += isohybrid.pl # about to be obsoleted