aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/files/use-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/files/use-ldflags.patch')
-rw-r--r--meta/recipes-extended/at/files/use-ldflags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/files/use-ldflags.patch b/meta/recipes-extended/at/files/use-ldflags.patch
new file mode 100644
index 0000000000..7d3d91a19a
--- /dev/null
+++ b/meta/recipes-extended/at/files/use-ldflags.patch
@@ -0,0 +1,21 @@
+# Ensure use of $LDFLAGS during build
+# Derived from an OE patch for at-3.1.8
+
+--- at-3.1.12.orig/Makefile.in 2009-11-23 07:11:52.000000000 -0800
++++ at-3.1.12/Makefile.in 2010-07-20 16:28:04.000000000 -0700
+@@ -65,13 +65,13 @@
+ all: at atd atrun
+
+ at: $(ATOBJECTS)
+- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
++ $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB) $(LDFLAGS)
+ rm -f $(CLONES)
+ $(LN_S) -f at atq
+ $(LN_S) -f at atrm
+
+ atd: $(RUNOBJECTS)
+- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
++ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB) $(LDFLAGS)
+
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y