summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb')
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
new file mode 100644
index 0000000000..bb01f71d01
--- /dev/null
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
@@ -0,0 +1,40 @@
+SUMMARY = "OpenPrinting printer support - filters"
+DESCRIPTION = "Foomatic is a printer database designed to make it easier to set up \
+common printers for use with UNIX-like operating systems.\
+It provides the "glue" between a print spooler (like CUPS or lpr) and \
+the printer, by processing files sent to the printer. \
+ \
+This package consists of filters used by the printer spoolers \
+to convert the incoming PostScript data into the printer's native \
+format using a printer-specific, but spooler-independent PPD file. \
+"
+
+DEPENDS += "cups perl libxml2"
+PR = "r0"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "b05f5dcbfe359f198eef3df5b283d896"
+SRC_URI[sha256sum] = "a2e2e53e502571e88eeb9010c45a0d54671f15707ee104f5c9c22b59ea7a33e3"
+
+inherit autotools
+
+EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
+
+do_configure_prepend() {
+ export PERL="${bindir}/env perl"
+ export LIB_CUPS=${exec_prefix}/lib/cups # /usr/lib NOT libdir
+ export CUPS_BACKENDS=${exec_prefix}/lib/cups/backend # /usr/lib NOT libdir
+ export CUPS_FILTERS=${exec_prefix}/lib/cups/filter # /usr/lib NOT libdir
+ export CUPS_PPDS=${datadir}/cups/model
+}
+
+do_install_append_linuxstdbase() {
+ install -d ${D}${exec_prefix}/lib/cups/filter
+ ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
+}
+
+FILES_${PN} += "${exec_prefix}/lib/cups/ ${exec_prefix}/lib/ppr/"