aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/less/less_470.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/less/less_470.bb')
-rw-r--r--meta/recipes-extended/less/less_470.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/less/less_470.bb b/meta/recipes-extended/less/less_470.bb
new file mode 100644
index 0000000000..566832960f
--- /dev/null
+++ b/meta/recipes-extended/less/less_470.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Text file viewer similar to more"
+DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
+based program for viewing text files and the output from other \
+programs. Less offers many features beyond those that more does."
+HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
+
+# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
+# Including email author giving permissing to use BSD
+#
+# From: Mark Nudelman <markn@greenwoodsoftware.com>
+# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
+# Date: 12/19/11
+#
+# Hi Elizabeth,
+# Using a generic BSD license for less is fine with me.
+# Thanks,
+#
+# --Mark
+#
+
+LICENSE = "GPLv3+ | BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE;md5=866cc220f330b04ae4661fc3cdfedea7"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "abf7c37b1a2c3d83865eba3ab2eb369f"
+SRC_URI[sha256sum] = "f191dc51144e7ea0e7f116118d0ee7a5fe50d1ce330257e1ae5ee4c9d35d86ef"
+
+inherit autotools update-alternatives
+
+do_install () {
+ oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+}
+
+ALTERNATIVE_${PN} = "less"
+ALTERNATIVE_PRIORITY = "100"