aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.6.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.6.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.6.bb b/meta/recipes-extended/pam/libpam_1.1.6.bb
index 7c0111fb04..7e55adfb04 100644
--- a/meta/recipes-extended/pam/libpam_1.1.6.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.6.bb
@@ -131,13 +131,13 @@ do_install() {
# The lsb requires unix_chkpwd has setuid permission
chmod 4755 ${D}${sbindir}/unix_chkpwd
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
echo "session optional pam_systemd.so" >> ${D}${sysconfdir}/pam.d/common-session
fi
}
python do_pam_sanity () {
- if not base_contains('DISTRO_FEATURES', 'pam', True, False, d):
+ if not bb.utils.contains('DISTRO_FEATURES', 'pam', True, False, d):
bb.warn("Building libpam but 'pam' isn't in DISTRO_FEATURES, PAM won't work correctly")
}
addtask pam_sanity before do_configure