summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch38
1 files changed, 23 insertions, 15 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch
index 90d4830df5..e638fd3b6f 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/0001-Fix-a-couple-of-decisions-around-cross-compilation.patch
@@ -1,23 +1,23 @@
-From 48cbdd56036728ffea431ad63cf5e2ad05cef69c Mon Sep 17 00:00:00 2001
+From bf71999b6e64d1f1919b0351b27c1c417e2b8856 Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Thu, 14 Feb 2019 18:06:25 +0100
-Subject: [PATCH] Fix a couple of decisions around cross-compilation
+Subject: [PATCH] Generate loaders.cache using a native tool when
+ cross-compiling
-1. gobject-introspection can be build when cross compiling
-2. generating loaders.cache requires running a target binary which
-we do elsewhere (in postinsts)
+Otherwise meson would attempt to run a target binary.
Upstream-Status: Pending
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
---
- gdk-pixbuf/meson.build | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
+ gdk-pixbuf/meson.build | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
diff --git a/gdk-pixbuf/meson.build b/gdk-pixbuf/meson.build
-index 77c162b..fc3eb33 100644
+index 1995ffd..d692cb7 100644
--- a/gdk-pixbuf/meson.build
+++ b/gdk-pixbuf/meson.build
-@@ -230,6 +230,7 @@ foreach bin: gdkpixbuf_bin
+@@ -291,6 +291,7 @@ foreach bin: gdkpixbuf_bin
set_variable(bin_name.underscorify(), bin)
endforeach
@@ -25,14 +25,22 @@ index 77c162b..fc3eb33 100644
# The 'loaders.cache' used for testing, so we don't accidentally
# load the installed cache; we always build it by default
loaders_cache = custom_target('loaders.cache',
-@@ -241,8 +242,9 @@ loaders_cache = custom_target('loaders.cache',
+@@ -302,6 +303,18 @@ loaders_cache = custom_target('loaders.cache',
],
build_by_default: true)
loaders_dep = declare_dependency(sources: [ loaders_cache ])
++else
++loaders_cache = custom_target('loaders.cache',
++ output: 'loaders.cache',
++ capture: true,
++ depends: [ dynamic_loaders_dep ],
++ command: [
++ 'gdk-pixbuf-query-loaders',
++ dynamic_loaders,
++ ],
++ build_by_default: true)
++loaders_dep = declare_dependency(sources: [ loaders_cache ])
+endif
--build_gir = get_option('with_gir') and not meson.is_cross_build()
-+build_gir = get_option('with_gir')
- if build_gir
- gir_args = [
- '--quiet',
+ pkgconfig = import('pkgconfig')
+ pkgconfig.generate(