summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.6.2.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.2.bb22
1 files changed, 12 insertions, 10 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.2.bb b/meta/recipes-graphics/freetype/freetype_2.6.2.bb
index 63e8ff4c1d..a41f5c80a0 100644
--- a/meta/recipes-graphics/freetype/freetype_2.6.2.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.6.2.bb
@@ -5,32 +5,32 @@ images). It can be used in graphics libraries, display servers, font conversion
image generation tools, and many other products as well."
HOMEPAGE = "http://www.freetype.org/"
BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
+SECTION = "libs"
LICENSE = "FreeType | GPLv2+"
LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=c017ff17fc6f0794adf93db5559ccd56 \
file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
-SECTION = "libs"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
file://use-right-libtool.patch"
+
SRC_URI[md5sum] = "86109d0c998787d81ac582bad9adf82e"
SRC_URI[sha256sum] = "baf6bdef7cdcc12ac270583f76ef245efe936267dbecef835f02a3409fcbb892"
-BINCONFIG = "${bindir}/freetype-config"
-
inherit autotools pkgconfig binconfig-disabled multilib_header
-EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
-TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
-
PACKAGECONFIG ??= "zlib"
+
PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
-PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
-PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
-# This results in a circular dependency so enabling is non-trivial
+# harfbuzz results in a circular dependency so enabling is non-trivial
PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
+PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+
+EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
+
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
do_configure() {
# Need this because although the autotools infrastructure is in
@@ -49,4 +49,6 @@ do_install_append() {
oe_multilib_header freetype2/freetype/config/ftconfig.h
}
+BINCONFIG = "${bindir}/freetype-config"
+
BBCLASSEXTEND = "native"