aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
new file mode 100644
index 0000000000..09c0f70f47
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_svn.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Matchbox window manager"
+HOMEPAGE = "http://matchbox-project.org"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
+ file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
+ file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
+
+SECTION = "x11/wm"
+DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf"
+
+PV = "1.2+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
+ file://configure_fix.patch;patch=1;maxrev=1818 \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager"
+
+inherit autotools pkgconfig update-alternatives
+
+ALTERNATIVE_NAME = "x-session-manager"
+ALTERNATIVE_LINK = "${bindir}/x-session-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+FILES_${PN} = "${bindir}/* \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+EXTRA_OECONF = " --enable-startup-notification \
+ --disable-xrm \
+ --enable-expat \
+ --with-expat-lib=${STAGING_LIBDIR} \
+ --with-expat-includes=${STAGING_INCDIR}"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}