aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.0.1.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.0.1.bb b/meta/recipes-graphics/mesa/mesa_17.0.1.bb
new file mode 100644
index 0000000000..9e491c28dc
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.0.1.bb
@@ -0,0 +1,17 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+ file://disable-asm-on-non-gcc.patch \
+ file://0001-Use-wayland-scanner-in-the-path.patch \
+"
+SRC_URI[md5sum] = "6a7e768241846c8c69bbadbf904dcc58"
+SRC_URI[sha256sum] = "96fd70ef5f31d276a17e424e7e1bb79447ccbbe822b56844213ef932e7ad1b0c"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}