aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/leafpad
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/leafpad')
-rw-r--r--meta/recipes-sato/leafpad/files/leafpad.desktop10
-rw-r--r--meta/recipes-sato/leafpad/files/owl-menu.patch61
-rw-r--r--meta/recipes-sato/leafpad/leafpad_0.8.17.bb28
3 files changed, 99 insertions, 0 deletions
diff --git a/meta/recipes-sato/leafpad/files/leafpad.desktop b/meta/recipes-sato/leafpad/files/leafpad.desktop
new file mode 100644
index 0000000000..c7e2d5bb58
--- /dev/null
+++ b/meta/recipes-sato/leafpad/files/leafpad.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Notes
+Exec=/usr/bin/leafpad
+Comment=Text Editor
+Icon=accessories-text-editor
+Terminal=false
+Type=Application
+Categories=GTK;Utility;TextEditor;
+X-MB-SingleInstance=true
+StartupNotify=true
diff --git a/meta/recipes-sato/leafpad/files/owl-menu.patch b/meta/recipes-sato/leafpad/files/owl-menu.patch
new file mode 100644
index 0000000000..acfc880307
--- /dev/null
+++ b/meta/recipes-sato/leafpad/files/owl-menu.patch
@@ -0,0 +1,61 @@
+--- tmp/src/menu.c.orig 2007-04-23 12:08:41.000000000 +0100
++++ tmp/src/menu.c 2007-04-23 12:08:41.000000000 +0100
+@@ -152,7 +152,7 @@
+ }
+
+ accel_group = gtk_accel_group_new();
+- ifactory = gtk_item_factory_new(GTK_TYPE_MENU_BAR, "<main>", accel_group);
++ ifactory = gtk_item_factory_new(GTK_TYPE_MENU, "<main>", accel_group);
+ gtk_item_factory_set_translate_func(ifactory, menu_translate, NULL, NULL);
+ gtk_item_factory_create_items(ifactory, nmenu_items, menu_items, NULL);
+ gtk_window_add_accel_group(GTK_WINDOW(window), accel_group);
+
+--- tmp/src/window.c.orig 2007-04-23 12:14:07.000000000 +0100
++++ tmp/src/window.c 2007-04-23 12:14:07.000000000 +0100
+@@ -18,6 +18,8 @@
+ */
+
+ #include "leafpad.h"
++#include <libowl/owlwindowmenu.h>
++
+ /*
+ static void cb_scroll_event(GtkAdjustment *adj, GtkWidget *view)
+ {
+@@ -52,7 +54,6 @@
+ gtk_container_add(GTK_CONTAINER(window), vbox);
+
+ menubar = create_menu_bar(window);
+- gtk_box_pack_start(GTK_BOX(vbox), menubar, FALSE, FALSE, 0);
+
+ sw = gtk_scrolled_window_new(NULL, NULL);
+ gtk_scrolled_window_set_policy(GTK_SCROLLED_WINDOW(sw),
+
+--- tmp/src/main.c.orig 2007-04-23 12:15:03.000000000 +0100
++++ tmp/src/main.c 2007-04-23 12:15:03.000000000 +0100
+@@ -244,6 +244,7 @@
+ Conf *conf;
+ GtkItemFactory *ifactory;
+ gchar *stdin_data = NULL;
++ GtkWidget *menu;
+
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ bind_textdomain_codeset(PACKAGE, "UTF-8");
+@@ -293,7 +294,10 @@
+ conf->autoindent);
+
+ gtk_widget_show_all(pub->mw->window);
++ owl_set_window_menu (GTK_WINDOW(pub->mw->window),
++ GTK_MENU(pub->mw->menubar));
++
+ g_free(conf->fontname);
+ g_free(conf);
+
+
+--- tmp/src/Makefile.am.orig 2007-04-23 12:17:54.000000000 +0100
++++ tmp/src/Makefile.am 2007-04-23 12:17:54.000000000 +0100
+@@ -27,4 +27,4 @@
+ i18n.h
+
+ leafpad_CFLAGS = $(GTK_CFLAGS) $(GNOMEPRINT_CFLAGS)
+-leafpad_LDADD = $(GTK_LIBS) $(INTLLIBS) $(GNOMEPRINT_LIBS)
++leafpad_LDADD = $(GTK_LIBS) $(INTLLIBS) $(GNOMEPRINT_LIBS) -lowl
diff --git a/meta/recipes-sato/leafpad/leafpad_0.8.17.bb b/meta/recipes-sato/leafpad/leafpad_0.8.17.bb
new file mode 100644
index 0000000000..5407b9e996
--- /dev/null
+++ b/meta/recipes-sato/leafpad/leafpad_0.8.17.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Simple GTK+ Text Editor"
+HOMEPAGE = "http://tarot.freeshell.org/leafpad/"
+BUGTRACKER = ""
+
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://src/leafpad.h;endline=20;md5=d3d6a89f5e61e8b13bdea537511ba1fa \
+ file://src/utils.c;endline=20;md5=0d2cc6584ba3202448bb274f62739571"
+
+DEPENDS = "gtk+ intltool-native"
+DEPENDS_append_poky = " libowl"
+SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
+ file://leafpad.desktop"
+PR = "r0"
+
+SRC_URI_append_poky += " file://owl-menu.patch;apply=yes "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-chooser --disable-gtktest --disable-print"
+
+do_install_append () {
+ install -d ${D}/${datadir}
+ install -d ${D}/${datadir}/applications
+ install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
+}
+
+FILES_${PN} += "${datadir}/applications/leafpad.desktop"