aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pimlico
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pimlico')
-rw-r--r--meta/recipes-sato/pimlico/contacts.inc31
-rw-r--r--meta/recipes-sato/pimlico/contacts/contacts-owl-window-menu.patch52
-rw-r--r--meta/recipes-sato/pimlico/contacts/stock_contact.pngbin0 -> 2311 bytes
-rw-r--r--meta/recipes-sato/pimlico/contacts/stock_person.pngbin0 -> 2280 bytes
-rw-r--r--meta/recipes-sato/pimlico/contacts_0.9.bb5
-rw-r--r--meta/recipes-sato/pimlico/contacts_git.bb17
-rw-r--r--meta/recipes-sato/pimlico/dates.inc20
-rw-r--r--meta/recipes-sato/pimlico/dates/dates-owl-window-menu.patch65
-rw-r--r--meta/recipes-sato/pimlico/dates_0.4.8.bb5
-rw-r--r--meta/recipes-sato/pimlico/dates_git.bb13
-rw-r--r--meta/recipes-sato/pimlico/tasks.inc16
-rw-r--r--meta/recipes-sato/pimlico/tasks/fix_pre-GTK+2.16.patch26
-rw-r--r--meta/recipes-sato/pimlico/tasks/tasks-owl.diff62
-rw-r--r--meta/recipes-sato/pimlico/tasks_0.16.bb14
-rw-r--r--meta/recipes-sato/pimlico/tasks_git.bb8
15 files changed, 334 insertions, 0 deletions
diff --git a/meta/recipes-sato/pimlico/contacts.inc b/meta/recipes-sato/pimlico/contacts.inc
new file mode 100644
index 0000000000..a424295aca
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "Address-book application."
+HOMEPAGE = "http://pimlico-project.org/contacts.html"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "GPLv2 & GPLv2+ & GPLv3+ "
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ eds-dbus"
+DEPENDS_append_poky = " libowl"
+RDEPENDS = "libedata-book"
+
+inherit autotools pkgconfig
+
+OWL = "--disable-owl"
+OWL_poky = "--enable-owl"
+
+EXTRA_OECONF += "--disable-gnome-vfs ${OWL}"
+EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1"
+
+do_install_append () {
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
+}
+
+FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
+ ${datadir}/pixmaps/stock_person.png"
+
+SRC_URI = "file://stock_contact.png \
+ file://stock_person.png"
+
+SRC_URI_append_poky = " file://contacts-owl-window-menu.patch;apply=yes "
diff --git a/meta/recipes-sato/pimlico/contacts/contacts-owl-window-menu.patch b/meta/recipes-sato/pimlico/contacts/contacts-owl-window-menu.patch
new file mode 100644
index 0000000000..4b9238b43a
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts/contacts-owl-window-menu.patch
@@ -0,0 +1,52 @@
+Index: contacts-0.9/src/contacts-gtk.c
+===================================================================
+--- contacts-0.9.orig/src/contacts-gtk.c 2008-06-06 12:56:08.000000000 +0100
++++ contacts-0.9/src/contacts-gtk.c 2008-06-16 08:14:28.000000000 +0100
+@@ -220,8 +220,8 @@
+ vbox7 = gtk_vbox_new (FALSE, 0);
+ gtk_container_add (GTK_CONTAINER (main_window), vbox7);
+
+- main_menubar = gtk_menu_bar_new ();
+- gtk_box_pack_start (GTK_BOX (vbox7), main_menubar, FALSE, FALSE, 0);
++ main_menubar = gtk_menu_new ();
++ gtk_widget_show (main_menubar);
+
+ contacts_menu = gtk_menu_item_new_with_mnemonic (_("C_ontacts"));
+ gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu);
+Index: contacts-0.9/src/Makefile.am
+===================================================================
+--- contacts-0.9.orig/src/Makefile.am 2008-06-03 09:16:56.000000000 +0100
++++ contacts-0.9/src/Makefile.am 2008-06-16 08:15:34.000000000 +0100
+@@ -40,7 +40,7 @@
+ contacts-@FRONTEND@.c \
+ contacts-@FRONTEND@.h
+
+-contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS)
++contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) -lowl
+
+ contacts_LDFLAGS = @CONTACTS_LIBS@ @DBUS_LIBS@
+
+Index: contacts-0.9/src/contacts-main.c
+===================================================================
+--- contacts-0.9.orig/src/contacts-main.c 2008-06-06 10:26:52.000000000 +0100
++++ contacts-0.9/src/contacts-main.c 2008-06-16 08:14:28.000000000 +0100
+@@ -27,6 +27,8 @@
+ #include <libgnomevfs/gnome-vfs.h>
+ #endif
+
++#include <libowl/owlwindowmenu.h>
++
+ #include "bacon-message-connection.h"
+ #include "contacts-defs.h"
+ #include "contacts-utils.h"
+@@ -266,6 +268,10 @@
+ gtk_widget_show_all (widget);
+ }
+
++ gtk_widget_show_all (data->ui->main_menubar);
++ owl_set_window_menu (GTK_WINDOW (data->ui->main_window),
++ GTK_MENU (data->ui->main_menubar));
++
+ gtk_main ();
+
+ /* if we have modified the current contact, but not saved it, do so now */
diff --git a/meta/recipes-sato/pimlico/contacts/stock_contact.png b/meta/recipes-sato/pimlico/contacts/stock_contact.png
new file mode 100644
index 0000000000..123b4485ac
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts/stock_contact.png
Binary files differ
diff --git a/meta/recipes-sato/pimlico/contacts/stock_person.png b/meta/recipes-sato/pimlico/contacts/stock_person.png
new file mode 100644
index 0000000000..2b1328b4e2
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts/stock_person.png
Binary files differ
diff --git a/meta/recipes-sato/pimlico/contacts_0.9.bb b/meta/recipes-sato/pimlico/contacts_0.9.bb
new file mode 100644
index 0000000000..1e4628737d
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts_0.9.bb
@@ -0,0 +1,5 @@
+require contacts.inc
+
+PR = "r2"
+
+SRC_URI =+ "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz"
diff --git a/meta/recipes-sato/pimlico/contacts_git.bb b/meta/recipes-sato/pimlico/contacts_git.bb
new file mode 100644
index 0000000000..bff4e288db
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts_git.bb
@@ -0,0 +1,17 @@
+require contacts.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://src/contacts-main.h;endline=20;md5=9dc3531c914fb6d6d4a8d1aee4519fef \
+ file://src/contacts-dbus.c;endline=20;md5=95e02d77f155fbd07a14dba3348b9b03 \
+ file://src/contacts-gtk.c;endline=23;md5=e1ee9b9e72045f2d3aa44cf17313b46e"
+
+PV = "0.12+git${SRCPV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI =+ "git://git.gnome.org/${PN};protocol=git"
+
+S = "${WORKDIR}/git"
+
+
diff --git a/meta/recipes-sato/pimlico/dates.inc b/meta/recipes-sato/pimlico/dates.inc
new file mode 100644
index 0000000000..6ef7b60611
--- /dev/null
+++ b/meta/recipes-sato/pimlico/dates.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Dates is a calendar application."
+HOMEPAGE = "http://pimlico-project.org/dates.html"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "GPLv2 & GPLv2+ & LGPLv2+"
+
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
+RDEPENDS = "libedata-cal"
+
+inherit autotools pkgconfig gtk-icon-cache
+
+# Poky/Sato specific enhancements
+OWL = "--disable-owl"
+OWL_poky = "--enable-owl --disable-dnd"
+
+EXTRA_OECONF += "${OWL}"
+DEPENDS_append_poky = " libowl"
+SRC_URI_append_poky = " file://dates-owl-window-menu.patch;apply=yes "
+
diff --git a/meta/recipes-sato/pimlico/dates/dates-owl-window-menu.patch b/meta/recipes-sato/pimlico/dates/dates-owl-window-menu.patch
new file mode 100644
index 0000000000..d5901658be
--- /dev/null
+++ b/meta/recipes-sato/pimlico/dates/dates-owl-window-menu.patch
@@ -0,0 +1,65 @@
+---
+ src/dates_gtk.c | 5 -----
+ src/dates_main.c | 5 +++++
+ src/dates_platform.h | 2 +-
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+Index: git/src/dates_gtk.c
+===================================================================
+--- git.orig/src/dates_gtk.c 2009-08-18 12:44:56.000000000 +0100
++++ git/src/dates_gtk.c 2009-09-03 22:28:50.000000000 +0100
+@@ -33,10 +33,6 @@
+ #endif
+
+ #ifndef DATES_PLATFORM_create_main_window
+-/* the default implementation assumes that menu is GtkMenuBar */
+-#ifdef DATES_MENU_WITHOUT_BAR
+-#error Cannot use default create_main_window () if DATES_MENU_WITHOUT_BAR is defined !!!
+-#endif
+ static GtkWidget *
+ create_main_window (DatesData * d, GtkWidget * toolbar,
+ GtkWidget * menu, GtkAccelGroup * accel_group)
+@@ -59,7 +55,6 @@
+ gtk_container_add (GTK_CONTAINER (d->main_window), main_vbox);
+
+ gtk_widget_show (menu);
+- gtk_box_pack_start (GTK_BOX (main_vbox), menu, FALSE, FALSE, 0);
+
+ gtk_box_pack_end (GTK_BOX (main_vbox), toolbar, FALSE, FALSE, 0);
+ gtk_container_set_border_width (GTK_CONTAINER (toolbar), 3);
+Index: git/src/dates_main.c
+===================================================================
+--- git.orig/src/dates_main.c 2009-08-18 12:44:56.000000000 +0100
++++ git/src/dates_main.c 2009-09-03 22:29:21.000000000 +0100
+@@ -26,6 +26,8 @@
+ #include <libical/icaltime.h>
+ #include <gconf/gconf-client.h>
+
++#include <gtk/gtkmenuitem.h>
++#include <libowl/owlwindowmenu.h>
+ #include "dates_types.h"
+ #include "dates_platform.h"
+ #include "dates_callbacks.h"
+@@ -582,6 +584,9 @@
+ g_free (url_uri);
+ }
+
++ owl_set_window_menu (GTK_WINDOW (data.main_window),
++ GTK_MENU (data.main_menu));
++
+ gtk_main ();
+
+ return 0;
+Index: git/src/dates_platform.h
+===================================================================
+--- git.orig/src/dates_platform.h 2009-08-18 12:44:56.000000000 +0100
++++ git/src/dates_platform.h 2009-09-03 22:28:50.000000000 +0100
+@@ -20,7 +20,7 @@
+
+ #include "dates_types.h"
+
+-#ifdef WITH_HILDON
++#if 1
+ #define DATES_MENU_WITHOUT_BAR 1
+ #endif
+
diff --git a/meta/recipes-sato/pimlico/dates_0.4.8.bb b/meta/recipes-sato/pimlico/dates_0.4.8.bb
new file mode 100644
index 0000000000..13afc157d0
--- /dev/null
+++ b/meta/recipes-sato/pimlico/dates_0.4.8.bb
@@ -0,0 +1,5 @@
+require dates.inc
+
+PR = "r3"
+
+SRC_URI = "http://pimlico-project.org/sources/dates/dates-${PV}.tar.gz"
diff --git a/meta/recipes-sato/pimlico/dates_git.bb b/meta/recipes-sato/pimlico/dates_git.bb
new file mode 100644
index 0000000000..49ca4eca86
--- /dev/null
+++ b/meta/recipes-sato/pimlico/dates_git.bb
@@ -0,0 +1,13 @@
+require dates.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/dates_view.h;endline=22;md5=29f934f356eb970309cdeb6693b3123a \
+ file://src/dates_hildon.c;endline=19;md5=63938904198b25de429abb65fbdbdb8a \
+ file://src/gconf-bridge.c;endline=22;md5=ad7626c6daf4aec590474a243f4912fa"
+
+PV = "0.4.11+git${SRCPV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git.gnome.org/${PN};protocol=git"
diff --git a/meta/recipes-sato/pimlico/tasks.inc b/meta/recipes-sato/pimlico/tasks.inc
new file mode 100644
index 0000000000..7478408447
--- /dev/null
+++ b/meta/recipes-sato/pimlico/tasks.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Task list application"
+HOMEPAGE = "http://pimlico-project.org/tasks.html"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "GPLv2 & GPLv2+"
+
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ eds-dbus"
+DEPENDS_append_poky = " libowl"
+
+inherit autotools pkgconfig gtk-icon-cache
+
+OWL ?= "--disable-owl"
+OWL_poky ?= "--enable-owl"
+
+EXTRA_OECONF += "${OWL}"
diff --git a/meta/recipes-sato/pimlico/tasks/fix_pre-GTK+2.16.patch b/meta/recipes-sato/pimlico/tasks/fix_pre-GTK+2.16.patch
new file mode 100644
index 0000000000..6c458d2601
--- /dev/null
+++ b/meta/recipes-sato/pimlico/tasks/fix_pre-GTK+2.16.patch
@@ -0,0 +1,26 @@
+commit ea52d46d691c5fce4473ea4e24a35411381f3a65
+Author: Ross Burton <ross@linux.intel.com>
+Date: Fri Aug 21 14:23:21 2009 +0100
+
+ Fix compilation on pre-GTK+ 2.16
+
+diff --git a/libkoto/koto-field-editor-factory.c b/libkoto/koto-field-editor-factory.c
+index bb776ab..d0e5328 100644
+--- a/libkoto/koto-field-editor-factory.c
++++ b/libkoto/koto-field-editor-factory.c
+@@ -132,6 +132,7 @@ entry_set (GtkWidget *widget, icalproperty *prop)
+ * URL entries.
+ */
+
++#if HAVE_DECL_GTK_ENTRY_SET_ICON_FROM_ICON_NAME
+ static void
+ url_entry_icon_clicked (GtkEntry *entry,
+ GtkEntryIconPosition icon_pos,
+@@ -146,7 +147,6 @@ url_entry_icon_clicked (GtkEntry *entry,
+ }
+ }
+
+-#if HAVE_DECL_GTK_ENTRY_SET_ICON_FROM_ICON_NAME
+ static void
+ on_url_entry_changed (GtkEntry *entry)
+ {
diff --git a/meta/recipes-sato/pimlico/tasks/tasks-owl.diff b/meta/recipes-sato/pimlico/tasks/tasks-owl.diff
new file mode 100644
index 0000000000..e4078066f5
--- /dev/null
+++ b/meta/recipes-sato/pimlico/tasks/tasks-owl.diff
@@ -0,0 +1,62 @@
+Index: src/gtk/tasks-ui.xml
+===================================================================
+--- src/gtk/tasks-ui.xml (revision 338)
++++ src/gtk/tasks-ui.xml (working copy)
+@@ -7,17 +7,14 @@
+ <menuitem action="EditTask"/>
+ <menuitem action="CompleteTask"/>
+ <separator/>
++ <menuitem action="Undo"/>
++ <menuitem action="Redo"/>
++ <separator/>
+ <menuitem action="DeleteTask"/>
+ <menuitem action="PurgeTasks"/>
+ <separator/>
++ <menuitem action="About"/>
+ <menuitem action="Quit"/>
+ </menu>
+- <menu action="EditMenu">
+- <menuitem action="Undo"/>
+- <menuitem action="Redo"/>
+- </menu>
+- <menu action="HelpMenu">
+- <menuitem action="About"/>
+- </menu>
+ </menubar>
+ </ui>
+Index: src/gtk/main.c
+===================================================================
+--- src/gtk/main.c (revision 338)
++++ src/gtk/main.c (working copy)
+@@ -21,6 +21,7 @@
+ #include <libecal/e-cal.h>
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
++#include <libowl/owlwindowmenu.h>
+
+ #include <libkoto/ical-util.h>
+ #include <libkoto/koto-actions.h>
+@@ -564,8 +565,8 @@
+ gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager));
+ gtk_ui_manager_ensure_update (ui_manager);
+
+- menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar");
+- gtk_box_pack_start (GTK_BOX (top_box), menu, FALSE, FALSE, 0);
++ menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu");
++ owl_set_window_menu_item (GTK_WINDOW (window), GTK_MENU_ITEM (menu));
+
+ box = gtk_vbox_new (FALSE, 4);
+ gtk_container_set_border_width (GTK_CONTAINER (box), 4);
+Index: src/gtk/Makefile.am
+===================================================================
+--- src/gtk/Makefile.am (revision 338)
++++ src/gtk/Makefile.am (working copy)
+@@ -4,7 +4,7 @@
+ bin_PROGRAMS = tasks
+ tasks_CPPFLAGS = -I$(top_srcdir)/
+ tasks_CFLAGS = $(WARN_CFLAGS) $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS)
+-tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS)
++tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl
+
+ tasks_SOURCES = \
+ main.c \
diff --git a/meta/recipes-sato/pimlico/tasks_0.16.bb b/meta/recipes-sato/pimlico/tasks_0.16.bb
new file mode 100644
index 0000000000..999da76529
--- /dev/null
+++ b/meta/recipes-sato/pimlico/tasks_0.16.bb
@@ -0,0 +1,14 @@
+require tasks.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://src/gtk/main.c;endline=19;md5=8659d0b7fd68a2ad6ac30c6539ea5b82 \
+ file://src/omoko/openmoko-tasks.c;endline=20;md5=04d56a46863c9f4247694f40257a836a \
+ file://src/hildon/hildon-tasks.c;endline=21;md5=488ddf31dc14b2196dec7cc736211b52"
+
+SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \
+ file://fix_pre-GTK+2.16.patch;apply=yes \
+ "
+
+OWL_poky = "--with-owl"
+
+PR = "r0"
diff --git a/meta/recipes-sato/pimlico/tasks_git.bb b/meta/recipes-sato/pimlico/tasks_git.bb
new file mode 100644
index 0000000000..1ab8cd18cd
--- /dev/null
+++ b/meta/recipes-sato/pimlico/tasks_git.bb
@@ -0,0 +1,8 @@
+require tasks.inc
+
+SRC_URI = "git://git.gnome.org/${PN};protocol=git"
+
+PV = "0.13+git${SRCPV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"