aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch103
1 files changed, 90 insertions, 13 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch b/meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch
index 27640129e2..2a2c1e9c21 100644
--- a/meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch
+++ b/meta/recipes-support/libgpg-error/libgpg-error-1.12/pkgconfig.patch
@@ -5,22 +5,22 @@
Upstream-Status: Pending
-Index: libgpg-error-1.8/configure.ac
+Index: libgpg-error-1.12/configure.ac
===================================================================
---- libgpg-error-1.8.orig/configure.ac 2010-05-06 06:01:08.000000000 -0700
-+++ libgpg-error-1.8/configure.ac 2010-07-21 02:20:20.923261305 -0700
-@@ -140,6 +140,7 @@
- AC_SUBST(GPG_ERROR_CONFIG_CFLAGS)
- AC_SUBST(GPG_ERROR_CONFIG_ISUBDIRAFTER)
+--- libgpg-error-1.12.orig/configure.ac 2014-05-13 21:14:26.846393236 +0000
++++ libgpg-error-1.12/configure.ac 2014-05-13 21:14:26.926393236 +0000
+@@ -217,6 +217,7 @@
+ AC_CONFIG_FILES([lang/Makefile lang/cl/Makefile lang/cl/gpg-error.asd])
+ AC_CONFIG_FILES([src/versioninfo.rc])
AC_CONFIG_FILES([src/gpg-error-config], [chmod +x src/gpg-error-config])
+AC_CONFIG_FILES([src/gpg-error.pc])
+ AC_OUTPUT
- # Special defines for certain platforms
-Index: libgpg-error-1.8/src/Makefile.am
+Index: libgpg-error-1.12/src/Makefile.am
===================================================================
---- libgpg-error-1.8.orig/src/Makefile.am 2010-04-14 02:16:44.000000000 -0700
-+++ libgpg-error-1.8/src/Makefile.am 2010-07-21 02:22:36.655012496 -0700
+--- libgpg-error-1.12.orig/src/Makefile.am 2014-05-13 21:14:26.846393236 +0000
++++ libgpg-error-1.12/src/Makefile.am 2014-05-13 21:14:26.934393236 +0000
@@ -37,13 +37,15 @@
bin_SCRIPTS = gpg-error-config
m4datadir = $(datadir)/aclocal
@@ -38,18 +38,95 @@ Index: libgpg-error-1.8/src/Makefile.am
BUILT_SOURCES = err-sources.h err-codes.h code-to-errno.h code-from-errno.h \
err-sources-sym.h err-codes-sym.h errnos-sym.h gpg-error.h \
-Index: libgpg-error-1.8/src/gpg-error.pc.in
+Index: libgpg-error-1.12/src/gpg-error.pc.in
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ libgpg-error-1.8/src/gpg-error.pc.in 2010-07-21 02:20:20.923261305 -0700
-@@ -0,0 +1,10 @@
++++ libgpg-error-1.12/src/gpg-error.pc.in 2014-05-13 21:48:20.266382916 +0000
+@@ -0,0 +1,11 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
++host=@GPG_ERROR_CONFIG_HOST@
+
+Name: gpg-error
+Description: a library that defines common error values for all GnuPG components
+Version: @VERSION@
+Libs: -L{libdir} -lgpg-error
+Cflags: -I${includedir}
+Index: libgpg-error-1.12/src/gpg-error.m4
+===================================================================
+--- libgpg-error-1.12.orig/src/gpg-error.m4 2014-05-13 21:45:02.038383922 +0000
++++ libgpg-error-1.12/src/gpg-error.m4 2014-05-13 21:47:08.362383281 +0000
+@@ -15,58 +15,14 @@
+ dnl
+ AC_DEFUN([AM_PATH_GPG_ERROR],
+ [ AC_REQUIRE([AC_CANONICAL_HOST])
+- gpg_error_config_prefix=""
+- dnl --with-libgpg-error-prefix=PFX is the preferred name for this option,
+- dnl since that is consistent with how our three siblings use the directory/
+- dnl package name in --with-$dir_name-prefix=PFX.
+- AC_ARG_WITH(libgpg-error-prefix,
+- AC_HELP_STRING([--with-libgpg-error-prefix=PFX],
+- [prefix where GPG Error is installed (optional)]),
+- [gpg_error_config_prefix="$withval"])
+
+- dnl Accept --with-gpg-error-prefix and make it work the same as
+- dnl --with-libgpg-error-prefix above, for backwards compatibility,
+- dnl but do not document this old, inconsistently-named option.
+- AC_ARG_WITH(gpg-error-prefix,,
+- [gpg_error_config_prefix="$withval"])
++ min_gpg_error_version=ifelse([$1], ,0.0,$1)
+
+- if test x$gpg_error_config_prefix != x ; then
+- if test x${GPG_ERROR_CONFIG+set} != xset ; then
+- GPG_ERROR_CONFIG=$gpg_error_config_prefix/bin/gpg-error-config
+- fi
+- fi
++ PKG_CHECK_MODULES(GPG_ERROR, [gpg-error >= $min_gpg_error_version], [ok=yes], [ok=no])
+
+- AC_PATH_TOOL(GPG_ERROR_CONFIG, gpg-error-config, no)
+- min_gpg_error_version=ifelse([$1], ,0.0,$1)
+- AC_MSG_CHECKING(for GPG Error - version >= $min_gpg_error_version)
+- ok=no
+- if test "$GPG_ERROR_CONFIG" != "no" \
+- && test -f "$GPG_ERROR_CONFIG" ; then
+- req_major=`echo $min_gpg_error_version | \
+- sed 's/\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
+- req_minor=`echo $min_gpg_error_version | \
+- sed 's/\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
+- gpg_error_config_version=`$GPG_ERROR_CONFIG $gpg_error_config_args --version`
+- major=`echo $gpg_error_config_version | \
+- sed 's/\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
+- minor=`echo $gpg_error_config_version | \
+- sed 's/\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
+- if test "$major" -gt "$req_major"; then
+- ok=yes
+- else
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -ge "$req_minor"; then
+- ok=yes
+- fi
+- fi
+- fi
+- fi
+ if test $ok = yes; then
+- GPG_ERROR_CFLAGS=`$GPG_ERROR_CONFIG $gpg_error_config_args --cflags`
+- GPG_ERROR_LIBS=`$GPG_ERROR_CONFIG $gpg_error_config_args --libs`
+- AC_MSG_RESULT([yes ($gpg_error_config_version)])
+ ifelse([$2], , :, [$2])
+- gpg_error_config_host=`$GPG_ERROR_CONFIG $gpg_error_config_args --host 2>/dev/null || echo none`
++ gpg_error_config_host=`$PKG_CONFIG --variable=host gpg-error`
+ if test x"$gpg_error_config_host" != xnone ; then
+ if test x"$gpg_error_config_host" != x"$host" ; then
+ AC_MSG_WARN([[
+@@ -80,9 +36,6 @@
+ fi
+ fi
+ else
+- GPG_ERROR_CFLAGS=""
+- GPG_ERROR_LIBS=""
+- AC_MSG_RESULT(no)
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(GPG_ERROR_CFLAGS)