summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
* grep: upgrade to 2.21Chen Qi2014-12-271-2/+2
| | | | | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* xz: upgrade to latest stable release 5.2.0Chen Qi2014-12-271-2/+2
| | | | | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pciutils: add PACKAGECONFIG for 'hwdb'Chen Qi2014-12-271-1/+6
| | | | | | | | | Add PACKAGECONFIG for 'hwdb' to fix the following QA warning. WARNING: QA Issue: libpci rdepends on libudev, but it isn't a build dependency? [build-deps] WARNING: QA Issue: pciutils rdepends on libudev, but it isn't a build dependency? [build-deps] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pciutils: upgrade to 3.3.0Chen Qi2014-12-272-103/+3
| | | | | | | | | | lib-build-fix.patch is removed as it doesn't seem useful. do_compile_prepend is removed because it's not useful for the new version. The following line is removed as I don't see any problem without it. PARALLEL_MAKE = "" Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sudo: upgrade to latest state version 1.8.11p2Chen Qi2014-12-272-9/+11
| | | | | | | | Files containing license information have changed position. FILES_${PN}-dev needs to be modified to contain correct files. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* tar: upgrade to 2.18Chen Qi2014-12-272-3/+2
| | | | | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* kmod: upgrade to 19Chen Qi2014-12-273-41/+14
| | | | | | | | | | | | | | 0001-Add-missing-O_CLOEXEC-in-kmod_module_get_size.patch is dropped as it's in the new version. Change-to-calling-bswap_-instead-of-htobe-and-be-toh.patch is modified to match the new version. License chesum is changed but it is confirmed that the license information is not chagned. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* boost : Add the atomic and chrono libraries to the build.Philip Balister2014-12-251-0/+2
| | | | | | | | Inspection of buildhistory shows no existing libraries changed and the atmoic and chrono libraries are packaged individually. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* runqemu-internal: increase memory for qemuarm64Kai Kang2014-12-251-1/+1
| | | | | | | | | | Increase memory to 512M for qemuarm64. The original size 126M can't make task testimage pass, neither 256M. [YOCTO #7102] Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* elfutils: Update PREFERRED_VERSION after upgradeSaul Wold2014-12-251-1/+1
| | | | | | | | Since we normally fix the version of elfutils in tcmode-default, this needs to be updated after we upgrade the recipe itself. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* oeqa/selftest: fix test_force_task so it doesn't taint the entire buildPaul Eggleton2014-12-251-0/+1
| | | | | | | | | | Using -C sets a taint on the specified task, and m4-native is in the dependency chain for just about everything, which means that everything gets forced to rebuild. We don't need the influence of this test to extend outside of the test itself, so ensure that the taint gets cleared at the end of the test. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/selftest: populate pkgdata/shlibs in test_recipetool_create_gitPaul Eggleton2014-12-251-0/+2
| | | | | | | Build some recipes so that we have the needed data in the sysroot for recipetool to refer to when scanning for dependencies. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/selftest: improve failure messages for devtool testsPaul Eggleton2014-12-251-10/+10
| | | | | | | | assertTrue prints "False is not True" if it fails, which is pretty much useless. Use a more appropriate assertion test where practical and add a message where it isn't. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/selftest: skip test_incremental_image_generation if not using rpmPaul Eggleton2014-12-251-0/+3
| | | | | | | We have just implemented incremental ipk image generation, but at the moment this test doesn't support that, so skip it if not using rpm. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/selftest: fix test_event_handler for changes in bitbake outputPaul Eggleton2014-12-251-1/+1
| | | | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/utils: fix testcase decorator to allow calling tests individuallyPaul Eggleton2014-12-251-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | Without this, running tests individually failed with a traceback: $ oe-selftest --run-test buildoptions.ImageOptionsTests.test_incremental_image_generation 2014-12-23 14:40:37,636 - selftest - INFO - Checking that everything is in order before running the tests 2014-12-23 14:40:38,408 - selftest - INFO - Running bitbake -p 2014-12-23 14:40:40,235 - selftest - INFO - Loading tests from: oeqa.selftest.buildoptions.ImageOptionsTests.test_incremental_image_generation Traceback (most recent call last): File "/home/user/poky/scripts/oe-selftest", line 179, in <module> ret = main() File "/home/user/poky/scripts/oe-selftest", line 164, in main suite.addTests(loader.loadTestsFromName(test)) File "/usr/lib64/python2.7/unittest/loader.py", line 91, in loadTestsFromName module = __import__('.'.join(parts_copy)) File "/home/user/poky/meta/lib/oeqa/selftest/buildoptions.py", line 12, in <module> class ImageOptionsTests(oeSelfTest): File "/home/user/poky/meta/lib/oeqa/selftest/buildoptions.py", line 14, in ImageOptionsTests @testcase(761) NameError: global name 'func' is not defined Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* oeqa/utils: replace some tabs with spacesPaul Eggleton2014-12-252-47/+47
| | | | | | Python code should use spaces only for indentation. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* dpkg: Upgrade to 1.17.21Aníbal Limón2014-12-256-204/+15
| | | | | | | | | | Remove dpkg-1.17.4-CVE-2014-0471, dpkg-1.17.4-CVE-2014-0471-CVE-2014-3127 and ignore_extra_fields patches that are already in upstream. Rebase no-vla-warning patch. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pythonnative: set PYTHON_EXECUTABLE so that cmake can find itAndreas Müller2014-12-241-0/+2
| | | | | | | | | | CMake Error at /home/a.mueller/tmp/oe-core-glibc/sysroots/x86_64-linux/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message): | Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) [RP: Added comment that is used by cmake] Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* wic: account for mmcblk device partition namingMaciej Borzecki2014-12-241-4/+12
| | | | | | | | | | | MMC block device partitions are named differently than other block devices and use the scheme: mmcblk<devnum>p<partnum>, ex: mmcblk0p1, mmcblk0p2. The current code generates incorrect parition names missing 'p' infix for fstab entries. The patch resolves this problem. Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* lsb: remove sendmail from sysrootRobert Yang2014-12-241-0/+8
| | | | | | | | | The sysroot/${libdir}/sendmail conflicts with esmtp's, and it's a symlink to ${sbindir}/sendmail which is meaningless for sysroot, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* bind: fix conf.patch to add db.255 configuration fileChen Qi2014-12-241-0/+16
| | | | | | | | | Add in conf.patch /etc/bind/db.255 file so that we don't get the following error. zone 255.in-addr.arpa/IN: loading from master file /etc/bind/db.255 failed: file not found Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* image.bbclass: avoid boot error on read-only systemd imageChen Qi2014-12-241-0/+21
| | | | | | | | | | | | | | | | | | | | | New version of systemd implements a new feature of updating /etc or /var when needed at boot. For details, please see link below. Opointer.de/blog/projects/stateless.html For now, at boot time, the systemd-sysusers.service would update user database files (/etc/passwd, /etc/group, etc.) according to the configuration files under /usr/lib/sysusers.d. This step is necessary for other systemd services to work correctly. Examples of such services are systemd-resolved and systemd-tmpfiles-setup. The problem is that on a read-only file system, that is, if /etc is read-only, the user database files could not be updated, causing failures of services. This patch fixes this problem by adding users/groups at rootfs time. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* license.bbclass: hardlink requires write permissionRobert Yang2014-12-241-2/+2
| | | | | | | | | | | | | | | | Fixed: * The os.link() reqiures write permission on the src file (suppose the src file belongs to another user, then you need write permission to harlink to it since the link count would change) * Print more info when failed to copy The warning was like: WARNING: Could not copy license file COPYING: [Errno 1] Operation not permitted We couldn't know which recipe print the warning from this message. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* opkg-collateral: Use new lists_dir syntaxPaul Barker2014-12-241-1/+1
| | | | | | | | | Since opkg v0.2.3, it has been possible to use the new syntax for the 'lists_dir' option in an opkg configuration file. From v0.3.0, this new syntax is required. The new syntax matches the way other options are set. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ppp: upgrade 2.4.7Hongxu Jia2014-12-241-2/+2
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pax-utils: upgrade to 0.9.2Hongxu Jia2014-12-241-2/+2
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* apr-util: upgrade to 1.5.4Hongxu Jia2014-12-241-2/+2
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libxml2: upgrade to 2.9.2Hongxu Jia2014-12-244-9/+63
| | | | | | | | | | | | | | | | - Rebase python-sitepackages-dir.patch to 2.9.2 - Drop libxml2-CVE-2014-3660.patch which has been merged to 2.9.2. - Add configure.ac-fix-cross-compiling-warning.patch to fix cross compilation failure. - Tweak do_configure_prepend, use configure.ac to instead of configure.in - Add cmake files to ${PN}-dev Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* license: Validate if LICENSE is well defined.Aníbal Limón2014-12-242-0/+23
| | | | | | | | | | | Add check_license_format function that shows warning if LICENSE don't have valid operators and also if have space separated entries without operator, add check_license_format validation into base class. [YOCTO #6758] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* license_class: fix license.manifest shows LICENSE field differently to recipeAníbal Limón2014-12-241-6/+7
| | | | | | | | | | Drop removal of [|&()*] operators in pkged_lic because this removal is only needed to validate if license is collected. [YOCTO #6757] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* logrotate: upgrade to 3.8.8Robert Yang2014-12-242-10/+10
| | | | | | | | * Upgrade to 3.8.8. * Update disable-check-different-filesystems.patch since we still need it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* lib/oe/image.py: Handle compressed IMAGE_TYPEDEP valuesOtavio Salvador2014-12-241-2/+16
| | | | | | | | | | When computing the dependency graph for the image generation, we need to take into account the compression type and identify the base type it relates to. This allow for a more robust graph generation even when using composed image types. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* image_types.bbclass: Rework code to map types for 'ext3'Otavio Salvador2014-12-241-1/+1
| | | | | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* image_types.bbclass: Respect IMAGE_TYPEDEP dependenciesOtavio Salvador2014-12-241-0/+2
| | | | | | | | The IMAGE_TYPEDEP dependencies also need to be taken into account when building an IMAGE_FSTYPE. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* init-ifupdown: Add missing script for qemuarm64Richard Purdie2014-12-231-0/+5
| | | | Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libpng 1.6.13: fix build for aarch64Koen Kooi2014-12-231-1/+1
| | | | | | | | | | | | The configure override was too restrictive, it needed both 'arm' and 'neon' to trigger, which breaks on aarch64. Since TUNE_FEATURES is the only qualifier that matters, drop the 'arm' override. Buildtested for 'genericarmv8' and 'qemux86' machines. [RP: Added class-target override to avoid failures for libpng-native] Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* make: upgrade to 4.1Robert Yang2014-12-231-2/+2
| | | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* git: upgrade to 2.2.0Robert Yang2014-12-231-2/+2
| | | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* rsync: upgrade to 3.1.1Robert Yang2014-12-221-2/+2
| | | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* wget: add PACKAGECONFIG for util-linuxRobert Yang2014-12-221-0/+3
| | | | | | | | Fixed: WARNING: QA Issue: wget rdepends on util-linux-libuuid, but it isn't a build dependency? [build-deps] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* wget: upgrade to 1.16.1Robert Yang2014-12-223-9/+9
| | | | | | | | | | * upgrade to 1.16.1 * inherit pkgconfig to fix the error like:a | configure.ac:41: error: possibly undefined macro: AC_MSG_NOTICE | configure.ac:89: error: possibly undefined macro: AS_IF Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* file: upgrade to 5.21Robert Yang2014-12-222-4/+4
| | | | | | | | * Upgrade to 5.21. * The debian-742262.patch is still needed. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* runqemu-internal: Fix qemu networking for qemuarm64Richard Purdie2014-12-221-2/+2
| | | | | | | This brings qemuarm64 into feature parity with the other qemu machines and enables the automated testing on the autobuilder. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* linux-yocto: Fixup linux-yocto for aarch64Mark Hatle2014-12-223-2/+8
| | | | | | | | | | | linux-yocto is updated to pass the sysroot path to the compiler when necessary. linux-yocto_ver.bb are updated to reference the correct linux-yocto branchs and SRCREVs. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* aarch-arm64: Update tune filesMark Hatle2014-12-223-23/+44
| | | | | | | | | | | | | | arch-arm64 is the base tune file for aarch64. Update this to allow the system to work with both aarch32 and aarch64 (multilib). arch-armv8 is for compatibility, it simply uses the base config for now. feature-arm-thumb was updated, since aarch64 mode does NOT have thumb support. We should only be processing warnings and additional arguments if thumb support is enabled on the processor core. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* glibc-package: aarch64 enable symlink for ABI complianceMark Hatle2014-12-221-0/+16
| | | | | | | | | | aarch64 requires the ld.so to be present in /lib, even if the rest of the libraries are installed into an alternative directory. See: https://sourceware.org/glibc/wiki/ABIList Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gcc: Disable aarch64 multilib optionsMark Hatle2014-12-222-0/+33
| | | | | | | | We want to revert to default gcc behavior to support oe-core's ability to change the libdir. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* packagegroup-core-tools-profile: remove sysprof for aarch64Kai Kang2014-12-221-0/+2
| | | | | | | | Remove sysprof from packagegroup-core-tools-profile that sysprof doesn't support arch aarch64. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* kexec-tools: add aarch64 supportKai Kang2014-12-223-2/+805
| | | | | | | | | | Add patch from https://fedorapeople.org/~hrw/aarch64/for-fedora/kexec-aarch64.patch to add aarch64 support for kexec-tools. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>