summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
Commit message (Collapse)AuthorAgeFilesLines
* libidn: fix QA warning (uClibc)André Draszik2016-07-011-0/+1
| | | | | | | | | | | | | WARNING: libidn-1.32-r0 do_package_qa: QA Issue: libidn rdepends on libiconv, but it isn't a build dependency, missing libiconv in DEPENDS or PACKAGECONFIG? [build-deps] We already have virtual/libiconv which is set appropriately in all environments, so let's use it to fix the issue. (From OE-Core rev: 181918f5a3ce662f7df333c584c11f1c261f0269) Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pythonnative.bbclass, python3native.bbclass: export STAGING_INCDIR, ↵Alexander Kanavin2016-07-012-4/+0
| | | | | | | | | | | | | | | | | | | | | | | STAGING_LIBDIR, PYTHON variables We patch Python's distutils modules to access STAGING_INCDIR/LIBDIR, so when they are not set, scripts that utilize distutils (e.g. python-config) fail. Several recipes need to export those manually to prevent such failures, so let's do that in the class instead. PYTHON variable is exported because otherwise autotools' python.m4 macro will pick up its own internal default, which may not be the version that we want. glib recipe in particular was previously using Python 2.x during build due to python.m4 defaulting to it - now it's using Python 3.x, and so needs a small fix in deletion of *.pyc files. (From OE-Core rev: c1e0eb62f2d89b10b187016200018830b1c77945) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* tzdata: update to 2016eArmin Kuster2016-06-231-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | Changes affecting future time stamps Africa/Cairo observes DST in 2016 from July 7 to the end of October. Guess October 27 and 24:00 transitions. (Thanks to Steffen Thorsen.) For future years, guess April's last Thursday to October's last Thursday except for Ramadan. Changes affecting past time stamps Locations while uninhabited now use '-00', not 'zzz', as a placeholder time zone abbreviation. This is inspired by Internet RFC 3339 and is more consistent with numeric time zone abbreviations already used elsewhere. The change affects several arctic and antarctic locations, e.g., America/Cambridge_Bay before 1920 and Antarctica/Troll before 2005. Asia/Baku's 1992-09-27 transition from +04 (DST) to +04 (non-DST) was at 03:00, not 23:00 the previous day. (Thanks to Michael Deckers.) (From OE-Core rev: ddcf128e76ed0678ce42416531f4ecb309c57439) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* tzcode: update to 2016eArmin Kuster2016-06-231-4/+5
| | | | | | | | | | | | | | | | | | | | | | V2: typo in title (jet lagged) Changes to code zic now outputs a dummy transition at time 2**31 - 1 in zones whose POSIX-style TZ strings contain a '<'. This mostly works around Qt bug 53071 <https://bugreports.qt.io/browse/QTBUG-53071>. (Thanks to Zhanibek Adilbekov for reporting the Qt bug.) Changes affecting documentation and commentary tz-link.htm says why governments should give plenty of notice for time zone or DST changes, and refers to Matt Johnson's blog post. tz-link.htm mentions Tzdata for Elixir. (Thanks to Matt Johnson.) (From OE-Core rev: 5f3340e5c966f4233e0cd4ec468b20a1fd5a7346) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gzip: upgrade to 1.8Richard Purdie2016-06-153-13/+7
| | | | | | | | | | | | Drop the do_install musl append since the charset file is no longer installed. Refresh the patch. Also update the PREFERRED_VERSION. (From OE-Core rev: c57ab66984bff1ea5596ffe592a0ca1e9ba82ab0) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* man-pages: upgrade to 4.06Hongxu Jia2016-06-151-2/+2
| | | | | | | (From OE-Core rev: 62a2f5cc293e74df1090a83e87f24798cf5d5fa1) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libnewt/libnewt-python: upgrade to 0.52.19Hongxu Jia2016-06-153-19/+2
| | | | | | | | | - Drop remove_slang_include.patch, libnewt 0.52.19 has fixed it. (From OE-Core rev: 8e24a6ed1cd6fd91f9b4644b1fa199e516c25fa2) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ghostscript: upgrade to 9.19Hongxu Jia2016-06-156-200/+78
| | | | | | | | | | | | | | | | | | - Ghostscript and GhostPDL releases from version 9.19 have been moved to GitHub hosting, tweak download site - Drop 0001-Bug-696497-Fix-support-for-building-with-no-jbig2-de.patch, and 0002-Bug-696497-part-2-fix-support-for-building-with-a-JP.patch, ghostscript 9.19 has fixed them. - Fix QA Warning unrecognised options: --enable-little-endian. It use AC_C_BIGENDIAN to detect big/little endian. http://www.delorie.com/gnu/docs/autoconf/autoconf_64.html (From OE-Core rev: 227ca0a373b5a93602a419296ff1da1a96615ba2) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* tar: upgrade to 1.29Chen Qi2016-06-152-9/+16
| | | | | | | | | Refresh remove-gets.patch for the latest version. (From OE-Core rev: 8504817a5707df0f26a3049846532bfa4890f329) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* byacc: upgrade to 20160324Chen Qi2016-06-151-3/+4
| | | | | | | | | The license checksum is changed, but license type remains the same. (From OE-Core rev: 6bc378f6a7526d39029854899a55cb22cef48c03) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sudo: upgrade to 1.8.16Chen Qi2016-06-151-2/+2
| | | | | | | (From OE-Core rev: cab69cc57aba3b228cccae650f8b06dcf7d388af) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sysstat: upgrade to 11.3.4Chen Qi2016-06-152-8/+8
| | | | | | | | | The license checksum is changed but the license remains the same. (From OE-Core rev: 01990eb1c868710cd4fb7b52057cd2eb1713c595) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* grep: upgrade to 2.25Chen Qi2016-06-151-2/+2
| | | | | | | (From OE-Core rev: 155588a2b825c371610f3c4af190f8c41522dfa0) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libarchive: respect disable-acl configuration optionMaxin B. John2016-06-052-0/+67
| | | | | | | | | | | Update configure.ac to properly handle --disable-acl option [YOCTO #9668] (From OE-Core rev: 84fe3f29f2bdaf98c9beefdfede143084fba093b) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libarchive: Add PACKAGECONFIG for lz4 to ensure determinismRichard Purdie2016-06-041-0/+1
| | | | | | | | | | | | | | | | | | This avoids: WARNING: opkg-1_0.3.1-r0 do_package_qa: QA Issue: libopkg rdepends on lz4, but it isn't a build dependency, missing lz4 in DEPENDS or PACKAGECONFIG? [build-deps] and ERROR: build-appliance-image-15.0.0-r0 do_rootfs: Unable to install packages. Command '/home/pokybuild/yocto-autobuilder/yocto-worker/build-appliance/build/build/tmp/sysroots/x86_64-linux/usr/bin/smart --log-level=warning --data-dir=/home/pokybuild/yocto-autobuilder/yocto-worker/build-appliance/build/build/tmp/work/qemux86_64-poky-linux/build-appliance-image/15.0.0-r0/rootfs/var/lib/smart install -y packagegroup-core-boot@qemux86_64 packagegroup-core-ssh-openssh@all psplash@core2_64 kernel-dev@qemux86_64 packagegroup-core-x11-base@all kernel-devsrc@qemux86_64 smartpm@core2_64 packagegroup-self-hosted@all rpm@core2_64 locale-base-en-us@core2_64 locale-base-en-gb@core2_64' returned 1: Loading cache... Updating cache... ######################################## [100%] Computing transaction...error: Can't install libopkg1-1:0.3.1-r0.0@core2_64: no package provides lz4 >= 131+git0+d86dc9167 (From OE-Core rev: f12fe90a78ca1239691e8fd8f7b06ce59b8b72cc) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* watchdog: update to 5.15Alexander Kanavin2016-06-044-210/+2
| | | | | | | | | Removed patches are all merged upstream. (From OE-Core rev: e25b27c89dd13f5a311b49a974b4410e7993ddae) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* msmtp: update to 1.6.5Alexander Kanavin2016-06-041-2/+2
| | | | | | | (From OE-Core rev: c4f58052e13ebd9dd58ebe4a654ae725e10e85f8) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mc: update to 4.8.17Alexander Kanavin2016-06-041-2/+2
| | | | | | | (From OE-Core rev: 9689cd9a006e0ac3528be3718d0a1bb0950ad5e4) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* tzcode, tzdata: fix upstream version checkAlexander Kanavin2016-06-042-0/+2
| | | | | | | (From OE-Core rev: f5dd9d51b8ccbb5672581c9297eddec6f5c6067a) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* cups: fix upstream version checkAlexander Kanavin2016-06-041-1/+1
| | | | | | | (From OE-Core rev: 7bb667e6f2e4315d72808d295820b530ba3aba72) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libnewt-python: move to Python 3Alexander Kanavin2016-06-031-3/+3
| | | | | | | (From OE-Core rev: 70e39d11bffd3fa2bb143ea640e470c9da6748ba) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libuser: move to Python 3Alexander Kanavin2016-06-031-3/+5
| | | | | | | (From OE-Core rev: b2037a6d1735755ff44913d89c674303191954e0) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* packagegroup-core-full-cmdline: drop python-dbus from the list of servicesAlexander Kanavin2016-06-031-1/+0
| | | | | | | | | Any Python scripts should include this dependency explicitly. (From OE-Core rev: f0caf5765f7a969917639912ffccb1c32e2012d1) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libpam: update dependency listMaxin B. John2016-06-031-1/+1
| | | | | | | | | | | | | | Depend only on bison-native as configure script is checking only for bison binary and libpam itself doesn't need target bison. Add libxml2-native for deterministic build (it detects xmlcatalog and xmllint) (From OE-Core rev: d904d24a9cb1f15688b9924981d9c3d4dac7065f) Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* unzip: fix security issuesEdwin Plauchu2016-06-012-0/+140
| | | | | | | | | | | This patch avoids unzip fails to compile with compiler flags which elevate common string formatting issues into an error (-Wformat -Wformat-security -Werror=format-security). [YOCTO #9551] (From OE-Core rev: 2dd1c02fbc7492002df9030f50710e242369e8b2) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libarchive: Upgrade to v3.2.0Paul Barker2016-06-016-328/+3
| | | | | | | | | | | | | | All patches are removed as they are no longer needed. Most were merged into this release of libarchive. "0001-Set-xattrs-after-setting-times.patch" was dropped upstream after discussion, see https://github.com/libarchive/libarchive/pull/664. The COPYING file in libarchive had a couple of minor changes to clarify which files are under which copyrights but the overall license is unaffected. (From OE-Core rev: 4976382011106b9515e44359f2f6bb1d0c69fdb3) Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* cracklib: disable building the python moduleAlexander Kanavin2016-06-011-22/+3
| | | | | | | | | | It's tricky to convert to Python 3 and isn't required by anything in oe-core or meta-oe. (From OE-Core rev: a5aa15188b0c43432251039adc82c6c5cc453b2e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* python-native, python3-native: remove the use of exported HOST_SYS and ↵Alexander Kanavin2016-06-011-3/+0
| | | | | | | | | | | | | | BUILD_SYS variables The code that utilized them was superseded by the code (in the same patch!) that is utilizing STAGING_LIBDIR/STAGING_INCDIR, and wasn't correct in the first place as HOST_SYS is not necessarily the same as the sysroot directory name. (From OE-Core rev: 8834e81a38c24a066bb4fefa93da61011d0db244) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* msmtp: upgrade to 1.6.4Alexander Kanavin2016-05-301-2/+2
| | | | | | | | (From OE-Core rev: 494d875bb25a8d235c116c80558062508a45fd16) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libpam: update to 1.3.0Maxin B. John2016-05-304-199/+64
| | | | | | | | | | | | | | | | | 1.2.1 -> 1.3.0 Remove upstreamed patch: a) pam-no-innetgr.patch Refreshed the following patches for 1.3.0: a) crypt_configure.patch b) pam-unix-nullok-secure.patch (From OE-Core rev: ac512ff9fbe41428e3d71d3e943aaa871d8b155a) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* cpio: Add native variantMariano Lopez2016-05-301-0/+2
| | | | | | | | (From OE-Core rev: fb3457a454b045abf1fa6b560b8f96257a4405c1) Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ghostcript: Set UPSTREAM_CHECK_URI variableLeonardo Sandoval2016-05-301-0/+2
| | | | | | | | | | | Set UPSTREAM_CHECK_URI (a github location), so package checking system gets the latest version of the package. (From OE-Core rev: 94d80ae33e0671e439c845f25e54aab0ee69843b) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* diffutils: Add patch to fix gplv2 version with gcc6Richard Purdie2016-05-302-1/+33
| | | | | | (From OE-Core rev: 9c21339306a5e77ffd256f0a2b1759131109cb64) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* core-image-{minimal, testmaster}-initramfs: set COMPATIBLE_HOSTMartin Jansa2016-05-221-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | | * use the same COMPATIBLE_HOST restriction as initramfs-live-install(-testfs) to resolve ugly error when trying to build them e.g. for ARM: ERROR: Nothing RPROVIDES 'initramfs-live-install-testfs' (but /home/jenkins/oe/world/shr-core/openembedded-core/meta/recipes-extended/images/core-image-testmaster-initramfs.bb RDEPENDS on or otherwise requires it) ERROR: initramfs-live-install-testfs was skipped: incompatible with host arm-oe-linux-gnueabi (not in COMPATIBLE_HOST) NOTE: Runtime target 'initramfs-live-install-testfs' is unbuildable, removing... Missing or unbuildable dependency chain was: ['initramfs-live-install-testfs'] ERROR: Required build target 'core-image-testmaster-initramfs' has no buildable providers. Missing or unbuildable dependency chain was: ['core-image-testmaster-initramfs', 'initramfs-live-install-testfs'] ERROR: Nothing RPROVIDES 'initramfs-live-install' (but /home/jenkins/oe/world/shr-core/openembedded-core/meta/recipes-core/images/core-image-minimal-initramfs.bb RDEPENDS on or otherwise requires it) ERROR: initramfs-live-install was skipped: incompatible with host arm-oe-linux-gnueabi (not in COMPATIBLE_HOST) NOTE: Runtime target 'initramfs-live-install' is unbuildable, removing... Missing or unbuildable dependency chain was: ['initramfs-live-install'] ERROR: Required build target 'core-image-minimal-initramfs' has no buildable providers. Missing or unbuildable dependency chain was: ['core-image-minimal-initramfs', 'initramfs-live-install'] (From OE-Core rev: 8016b51d81ca9ed1567effa9d2870b1d98684350) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* net-tools: Fix rootfs creation errorsDai Caiyun2016-05-221-0/+4
| | | | | | | | | | | | | 1) error: file /usr/share/man/man1/hostname.1 from install of net-tools-doc conflicts with file from package coreutils-doc-6.9-r5 2) error: file /usr/share/man/man1/hostname.1 from install of net-tools-doc conflicts with file from package coreutils-doc-8.25 (From OE-Core rev: 4c98c19d5e16193efbf6865ed53369f9ef61d9a0) Signed-off-by: Dai Caiyun <daicy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* shadow: Fix rootfs creation errorsDai Caiyun2016-05-221-1/+2
| | | | | | | | | | | error: file /usr/share/man/man1/su.1 from install of shadow-doc-4.2.1 conflicts with file from package coreutils-doc-6.9-r5 (From OE-Core rev: 52d3d9e1ab0b510d93c4915baf2a85b9cc949205) Signed-off-by: Dai Caiyun <daicy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libsolv: update to 0.6.21Maxin B. John2016-05-222-40/+2
| | | | | | | | | | | | | 0.6.20 -> 0.6.21 Remove upstreamed patch: 1. 0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch (From OE-Core rev: 504a82289e42eb76268852015f0c5e463ced5556) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ghostscript: Update URL_SRI considered as 'old release'Leonardo Sandoval2016-05-221-1/+1
| | | | | | | | | | | | | | | | The Ghostcript project started to place their tarballs in two places starting at 9.19 as explained in [1]. 9.18 version is considered old, so including the 'old-gs-releases' in the URL. [1] http://downloads.ghostscript.com/public/ [YOCTO #9573] (From OE-Core rev: f4232f796875b007a438eb75fe438db6aba30572) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* zip: update SRC_URIRoss Burton2016-05-192-35/+32
| | | | | | | | | | | | | | | The infozip FTP server appears to have been taken down, so change the SRC_URI to point at their SourceForge project. Also as the SRC_URI can't be generated from the version and there is no other user of the .inc, merge the .bb and .inc together. [ YOCTO #9655 ] (From OE-Core rev: 5cb1e0ec46e4fde1c15aeb6812eaaece4840ac1c) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* unzip: update SRC_URIRoss Burton2016-05-191-1/+1
| | | | | | | | | | | | The infozip FTP server appears to have been taken down, so change the SRC_URI to point at their SourceForge project. [ YOCTO #9655 ] (From OE-Core rev: 879b2c5ee2ae39d6c1ae9d44ab243d8c7b7874b4) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* zip: fix security issuesEdwin Plauchu2016-05-192-1/+44
| | | | | | | | | | | | | This patch avoids zip recipe fails to compile with compiler flags which elevate common string formatting issues into an error (-Wformat -Wformat-security -Werror=format-security). [YOCTO #9552] (From OE-Core rev: f63a36360b7e138d2a63c84b5b1a8287ffe3d2ae) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* stat: fix security issuesEdwin Plauchu2016-05-192-0/+69
| | | | | | | | | | | | | This patch avoids stat fails to compile with compiler flags which elevate common string formatting issues into an error (-Wformat -Wformat-security -Werror=format-security). [YOCTO #9550] (From OE-Core rev: f03c1f41933e9997a01a8b1dcdf9fb18579de1d1) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libsolv: upgrade to 0.6.20Maxin B. John2016-05-172-3/+259
| | | | | | | | | | | | 0.6.19 -> 0.6.20 Added the following patch to fix build with musl: 0001-Add-fallback-fopencookie-implementation.patch (From OE-Core rev: dcc5d6bc2e3e5848f36fe1001b8cb65576047b7d) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libuser: Fix security string formatting issues.Aníbal Limón2016-05-152-1/+36
| | | | | | | | | [YOCTO #9547] (From OE-Core rev: c3f5a05f8d482608be964d200938ae3ed745fe09) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ltp: Fixes security string printf on testcases/network/nfsv4/acl/acl1.cAníbal Limón2016-05-152-0/+42
| | | | | | | | | [YOCTO #9548] (From OE-Core rev: 9738bbcee1f0ad274a2c62bb483311ef99238ea6) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mdadm: Fix build with clangKhem Raj2016-05-132-0/+44
| | | | | | | (From OE-Core rev: d701293b9de2e23cac2f1b57af5b3d44f489c404) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mdadm: Fix gcc 6 warningsKhem Raj2016-05-132-1/+39
| | | | | | | (From OE-Core rev: aa20503a8f93a134db5124e5a6b1ac5fff08cc87) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* shadow-sysroot: Use SYSROOT_DIRS to add dirs to stage in sysrootPeter Kjellerstedt2016-05-131-4/+2
| | | | | | (From OE-Core rev: 196e01cce6d76c72d8e76ad1441c1baed321c939) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mc: upgrade to 4.8.16Maxin B. John2016-05-111-2/+2
| | | | | | | | | | 4.8.15 -> 4.8.16 (From OE-Core rev: d56bcaede9c31ca28950de165c6f8585a8ea3e8d) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ethtool: upgrade to 4.5Maxin B. John2016-05-111-2/+2
| | | | | | | | | | 4.2 -> 4.5 (From OE-Core rev: e0e3ec613d5f84ae17a839558b3a3192bd4963ef) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>