summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm
Commit message (Collapse)AuthorAgeFilesLines
* libdrm: Upgrade to 2.4.62Steffen Pankratz2015-07-162-6/+7
| | | | | Signed-off-by: Steffen Pankratz <steffen.pankratz@elektrobit.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libdrm: remove git recipe, merge incRoss Burton2015-07-073-56/+38
| | | | | | | The git recipe hasn't been touched since 2012 and is out of date, so simplify the recipe by removing the git form and merging the remaining bb and inc file. Signed-off-by: Ross Burton <ross.burton@intel.com>
* libdrm: upgrade to 2.4.59Nicolas Dechesne2015-02-084-8/+7
| | | | | | | | | | | * Refreshed installtests.patch * Removed --enable-freedreno-experimental-api, since it is now enabled by default upstream Tested on Snapdragon 600 with freedreno and X11. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libdrm: Upgrade to 2.4.58.Aníbal Limón2014-12-054-38/+7
| | | | | | | | | | Disable man pages creation because it needs to download docbook.xsl from upstream site and sometimes can't (resource unavailable) and this cause build fails. Remove GNU_SOURCE_definition patch it's already integrated in upstream. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
* libdrm: enable freedreno experimental supportNicolas Dechesne2014-07-191-2/+4
| | | | | | | | | | The freedreno project is a free and open source linux driver for the 2D/3D GPUs in Qualcomm snapdragon SoCs. Support for freedreno in libdrm was added around 2.4.43. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.54Nicolas Dechesne2014-07-192-8/+8
| | | | | | | | | | | | | Version 2.4.54 was released a couple of months ago, see [1] for list of changes. The upgrade is required for using recent freedreno X11 driver on QCOM SoC. This was tested on IFC6410 board. [1] http://lists.x.org/archives/xorg-announce/2014-May/002426.html Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.53Laurentiu Palcu2014-04-302-8/+8
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: upgrade to 2.4.52Laurentiu Palcu2014-02-082-8/+8
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: use RRECOMMENDS for libdrm-driversChristopher Larson2013-12-161-2/+2
| | | | | | | | | | As libdrm enables modules automatically, based on what it needs / can build, it's unlikely we'll *ever* get a situation where all the modules are emitted, so libdrm-drivers, which depends on all of them, ends up being useless and non-installable. Make it use rrecommends, so it only pulls in what we have. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.49Laurentiu Palcu2013-11-272-8/+8
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.47Laurentiu Palcu2013-10-182-8/+8
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* remove the unnecessary protocol parametersJackie Huang2013-08-301-1/+1
| | | | | | | | | It's not necessary to specify the protocol parameter when it's the default protocol for the fetcher, e.g. the default protocol for git fetcher it git, "protocol=git" isn't needed. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.46Laurentiu Palcu2013-08-012-8/+8
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: upgrade to 2.4.45Laurentiu Palcu2013-06-132-8/+8
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: fix packaging after last upgradeMartin Jansa2013-05-291-1/+2
| | | | | | | | | | | | | * 2.4.44 adds 2 more tests kmstest and vbltest which got packaged to PN, causing PKG rename and breaking upgrade path * check_data_file_clashes: Package libdrm wants to install file /usr/lib/libdrm.so.2 But that file is already provided by package * libdrm2 * check_data_file_clashes: Package libdrm wants to install file /usr/lib/libdrm.so.2.4.0 But that file is already provided by package * libdrm2 put them to PN-tests where they belong Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: upgrade to 2.4.44Laurentiu Palcu2013-05-124-36/+9
| | | | | | | | Removed part of the installtests.patch since tests can now be installed giving an option to configure script. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: upgrade to 2.4.42Laurentiu Palcu2013-02-141-2/+2
| | | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: upgrade to 2.4.40Laurentiu Palcu2012-11-195-92/+27
| | | | | | | | | | | | Other changes: * removed a backported patch; * activated libdrm-omap helper layer which is needed by the latest xf86-video-omap xorg driver; * split libdrm-drivers package into libdrm-radeon, libdrm-nouveau and libdrm-omap, libdrm-intel and libdrm-exynos; Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Add --disable-cairo-tests switch and update to upstream patchDaniel Stone2012-10-184-41/+76
| | | | | | | | | | | Rather than implicitly relying on Cairo being disabled through not being present, add a configure switch to forcibly disable it. The updates the code to use a patch backported from upstream git instead of our custom version. Signed-off-by: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Bump git recipe to latest 2.4.39+ revisionDaniel Stone2012-10-181-2/+2
| | | | | Signed-off-by: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Explicitly disable the cairo dependencyRichard Purdie2012-10-053-0/+42
| | | | | | | | We don't want the cairo dependency. Unfortunately simply checking whether its present isn't good enough. If its not in DEPENDS, it can disappear half way through building. We therefore need to explictly disable it. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Remove Cairo dependencyDaniel Stone2012-10-021-2/+2
| | | | | | | | | | | This causes a build loop, when DRM depends on Cairo depends on Mesa depends on DRM. We can safely remove it as it's only one libdrm example program which uses Cairo, which we won't be needing. At least it's not worth the build loop. Signed-off-by: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.39Constantin Musca2012-09-031-2/+2
| | | | | Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: package update 2.4.35 -> 2.4.37Constantin Musca2012-08-151-2/+2
| | | | | Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: add DEFAULT_PREFERENCE = -1 to git recipeMartin Jansa2012-07-291-0/+2
| | | | | | | * recipe from tarball should be default version Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Bump libdrm_git to 2.4.37Damien Lespiau2012-07-281-2/+3
| | | | | | Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Put the license md5sum in the common includeDamien Lespiau2012-07-282-2/+1
| | | | | | | | With this, libdrm_git now does have LIC_FILES_CHKSUM as well. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: libdrm does not depend on xcb any moreDamien Lespiau2012-07-281-2/+2
| | | | | | Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* drm: move to PR/INC_PR, starting at r1 as libdrm_git was at r1Ross Burton2012-07-283-2/+4
| | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.35Laurentiu Palcu2012-07-041-2/+2
| | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
* libdrm: upgrade to 2.4.34Laurentiu Palcu2012-05-241-2/+2
| | | | Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
* libdrm: Update to version 2.4.31Saul Wold2012-02-281-3/+3
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* More quoting fixesMartin Jansa2012-02-261-1/+1
| | | | | | | | * We have various variables which are either not quoted at all or are half quoted. This patch fixes the bad exmaples so everything is consistent. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: Fix build failure unearthed by uclibcKhem Raj2012-02-072-2/+34
| | | | | | | | uclibc wants to know value of __USE_GNU for certain header prototypes to be enabled. So we move the config.h header up in search list. Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libdrm: Update to 2.4.30Saul Wold2012-02-021-2/+2
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: Upgrade to 2.4.29Saul Wold2011-12-211-4/+4
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: Update to 2.4.27Saul Wold2011-11-291-3/+3
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* libdrm: improve packagingMartin Jansa2011-10-043-5/+6
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libdrm: upgrade to 2.4.26Yu Ke2011-07-043-2/+5
| | | | Signed-off-by: Yu Ke <ke.yu@intel.com>
* recipes: Add Upstream-Status for multiple recipesYu Ke2011-05-121-1/+1
| | | | | | | | | | | | | iputils: update patch Upstream-Status mktemp: update patch Upstream-Status xinetd: update Upstream-Status libdrm: update patch Upstream-Status qemugl: update patch Upstream-Status x11-common: update patch Upstream-Status xorg-app: update patch Upstream-Status xorg-driver: update patch Upstream-Status Signed-off-by: Yu Ke <ke.yu@intel.com>
* poky-default-revisions: move the SRCREV to recipe fileYu Ke2011-05-041-0/+1
| | | | | | in this case, those non poky distro can also use these recipe normally Signed-off-by: Yu Ke <ke.yu@intel.com>
* libdrm: upgrade from 2.4.23 to 2.4.25Yu Ke2011-04-183-45/+52
| | | | Signed-off-by: Yu Ke <ke.yu@intel.com>
* recipes-graphics: Add more detailed SUMMARY and DESCRIPTIONSMark Hatle2011-02-031-2/+5
| | | | | | | | | | | | | Add more detailed SUMMARY and DESCRIPTIONS to various graphics and graphics related components. I've recently gotten question from users what something is, or why it was needed.. this should go a long way toward answering those questions. Many of the descriptions were taken directly from the upstream location, where one was not available the Debian packages were consulted for information. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
* libdrm: upgrade to 2.4.23Yu Ke2011-01-182-2/+2
| | | | Signed-off-by: Yu Ke <ke.yu@intel.com>
* recpies: use SRCPV instead of SRCREV for PVYu Ke2011-01-061-1/+1
| | | | | | | | SRCPV is intended being used by PV, some recipes still use SRCREV for PV, which is not correct. This patch fix all the misusage. Signed-off-by: Yu Ke <ke.yu@intel.com>
* recipes-graphics: Add SUMMARY and update DESCRIPTIONMark Hatle2010-12-161-0/+1
| | | | | | Add the missing SUMMARY fields and update DESCRIPTION fields if necessary Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
* libdrm: add license checksumYu Ke2010-12-021-0/+2
| | | | Signed-off-by: Yu Ke <ke.yu@intel.com>
* libdrm: upgrade from 2.4.21 to 2.4.22Yu Ke2010-11-223-4/+7
| | | | Signed-off-by: Yu Ke <ke.yu@intel.com>
* Major layout change to the packages directoryRichard Purdie2010-08-274-0/+69
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>