aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
Commit message (Collapse)AuthorAgeFilesLines
* at-spi2-atk: upgrade to 2.14.1.Ross Burton2014-12-311-2/+2
| | | | Signed-off-by: Ross Burton <ross.burton@intel.com>
* at-spi2-core: upgrade to 2.14.1Ross Burton2014-12-312-45/+3
| | | | | | Drop core_acinclude_m4.patch, merged upstream. Signed-off-by: Ross Burton <ross.burton@intel.com>
* atk: upgrade to 2.14.0Ross Burton2014-12-311-4/+4
| | | | | | | License checksums included some #includes so update the endline to match the license statement. Signed-off-by: Ross Burton <ross.burton@intel.com>
* sqlite3: Upgrade to 3.8.7.4Aníbal Limón2014-12-301-2/+2
| | | | | Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* boost : Add the atomic and chrono libraries to the build.Philip Balister2014-12-251-0/+2
| | | | | | | | Inspection of buildhistory shows no existing libraries changed and the atmoic and chrono libraries are packaged individually. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* apr-util: upgrade to 1.5.4Hongxu Jia2014-12-241-2/+2
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libunwind: add aarch64 supportFathi Boudra2014-12-224-0/+2607
| | | | | | | | | | | * pass --enable-debug-frame on aarch64 architecture * include patches: - aarch64 port (backported from upstream) - Support-building-with-older-compilers (fix undefined reference to `unreachable' on older compilers) Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* lttng: recognize aarch64Joe Slater2014-12-222-0/+20
| | | | | | | | Add aarch64 architecture to liburcu and lttng-ust. Internally it is treated the same as "arm". Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libproxy: let INCOMPATIBLE_LICENSE supports wildcardHongxu Jia2014-12-191-1/+1
| | | | | | | | | While wildcard in INCOMPATIBLE_LICENSE, such as INCOMPATIBLE_LICENSE = "*GPL-3", libproxy could correct work. [YOCTO #5592] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
* gnutls: upgrade to 3.3.11Armin Kuster2014-12-192-7/+6
| | | | | | | | | this also includes a fix for CVE-2014-8564. see http://www.gnutls.org/security.html for CVE-2014-3566 "POODLE" statement. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* serf: readded md5sumEnrico Scholz2014-12-111-0/+2
| | | | | | | | | | | | Commit 36d94ed631f1a753482282fced7d3b7505d5e03d ("serf: fix 'ccache' builds") removed the source md5sum accidentally while resolving a merge conflict. Readd it. Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de> Cc: Kang Kai <Kai.Kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* npth: npth needs pthread in some casesSaul Wold2014-12-111-1/+2
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* apr: avoid absolute paths for grepJackie Huang2014-12-111-0/+5
| | | | | | | | | | | | | | | | The apr provides usr/share/build-1/libtool which is required by the recipe such as apache2, and it will find grep on the host and set absolute paths in libtool: GREP="/usr/bin/grep" If we build apr/apr-native on a host that grep is in "/usr/bin/grep", and re-use the sstate on another host with "/bin/grep", it will fail when build apache2/apache2-native with: | tmp/sysroots/x86_64-linux/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory | tmp/sysroots/intel-x86-64/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* lzo: add debian patch for alignment issueSaul Wold2014-12-052-0/+71
| | | | | | | [YOCTO #6994] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libxslt: create wrapper to avoid host system referencingChen Qi2014-12-051-0/+5
| | | | | | | | | By default, xsltproc from libxslt would use configuration files under /etc/xml. To avoid host system contamination, we create a wrapper for this command to make it use configuration files in the sysroot directory. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gnutls: disable tpmChong Lu2014-12-051-0/+3
| | | | | | | | | | | Disable tpm to solve following error: .../usr/lib64/libtspi.la: No such file or directory trousers isn't an oe-core recipe, disable it for now. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* attr: use EXTRA_AUTORECONF to disable autoheaderRoss Burton2014-12-031-1/+1
| | | | | | | Disable autoheader by setting EXTRA_AUTORECONF to --exclude=autoheader instead of setting AUTOHEADER to true. Signed-off-by: Ross Burton <ross.burton@intel.com>
* serf: fix 'ccache' buildsEnrico Scholz2014-12-032-6/+31
| | | | | | | | | | | | | | | | | | | | | | | | | 'scons' cleans the environment which breaks ccache builds because CCACHEDIR can point to an unexpected location: | ccache arm-linux-gnueabi-gcc ... context.c | ccache: failed to create .../serf/1.3.8-r0/.home/.ccache (No such file or directory) Issue is described in http://www.scons.org/wiki/ImportingEnvironmentSettings and because 'bitbake' cleans environment we can pass it completely instead of trying to enumerate needed env. With the 'env.patch' the FULLCC variable is not needed anymore (which would break when CC is 'ccache arm-...-gcc' and host ccache is used) because the correct $PATH is available during scons build: | sh: .../sysroots/x86_64-oe-linux/usr/bin/arm-linux-gnueabi/ccache: No such file or directory | scons: *** [context.o] Error 127 Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
* boost: Upgrade to 1.57Saul Wold2014-12-034-415/+2
| | | | Signed-off-by: Saul Wold <sgw@linux.intel.com>
* npth: Upgrade to 1.1Saul Wold2014-12-032-2/+51
| | | | | | Add patch for adding pkgconfig file. Signed-off-by: Saul Wold <sgw@linux.intel.com>
* curl: Ugrade to 7.38Saul Wold2014-12-033-343/+3
| | | | | | Remove backported CVE patches Signed-off-by: Saul Wold <sgw@linux.intel.com>
* serf: 1.3.6 -> 1.3.8Wenzong Fan2014-11-251-3/+3
| | | | | | | | | | | | | | | Release changes: Serf 1.3.8 [2014-10-20, from /tags/1.3.8, rxxxx] Fix issue #152: CRC calculation error for gzipped http reponses > 4GB. Fix issue #153: SSPI CredHandle not freed when APR pool is destroyed. Fix issue #154: Disable SSLv2 and SSLv3 as both or broken. Serf 1.3.7 [2014-08-11, from /tags/1.3.7, r2411] Handle NUL bytes in fields of an X.509 certificate. (r2393, r2399) - CVE-2014-3504: (Closes: #757965) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
* nss: Upgrade to 3.17.2Chong Lu2014-11-122-8/+8
| | | | | Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* apr-native: Set CONFIG_SHELL to /bin/bashRobert Yang2014-11-121-0/+2
| | | | | | | | | | | | | | The apr-native provides usr/share/build-1/libtool which is required by the recipe such as apache2-native. If we don't set the CONFIG_SHELL to /bin/bash, then: 1) If we build apr-native on a host which is "/bin/sh -> bash", the interpreter in usr/share/build-1/libtool would be "#!/bin/sh". 2) When we re-use apr-native's sstate on a host which is "/bin/sh -> dash", there would be errors. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* beecrypt: add option --with-dev-dspKai Kang2014-11-122-0/+35
| | | | | | | | | | Add this configure option for developer to control if the /dev/dsp should be used on target. Instead of judging it based on the very device file of build server. Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libpcre: Upgrade to 8.36Chong Lu2014-11-092-3/+3
| | | | | Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* lz4: update to version r123Armin Kuster2014-11-091-2/+2
| | | | | | | | | | | Makefile md5sum changed since version is hardcode in it. Added : experimental lz4frame API; special thanks to Takayuki Matsuoka and Christopher Jackson for testings and suggestions Fix : s390x support, thanks to Nobuhiro Iwamatsu Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* pinentry: update 0.9Armin Kuster2014-11-091-8/+4
| | | | | | | | removed some EXTRA_OECONF to fix: WARNING: QA Issue: pinentry: configure was passed unrecognised options: --disable-glibtest --disable-pinentry-gtk --disable-pinentry-qt [unknown-configure-option] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* debianutils: Add recipe from meta-oeRicardo Ribalda Delgado2014-11-091-0/+35
| | | | | | | This recipe is a running dependency of recipe apt Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libksba: Ugrade to 1.3.1Saul Wold2014-11-091-3/+2
| | | | | Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libgcrypt: Ugrade to 1.6.2Saul Wold2014-11-093-175/+4
| | | | | | | Remove backported patch Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* liburcu: Ugrade to 0.8.5Saul Wold2014-11-091-2/+2
| | | | | Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* npth: Upgrade to 1.0Saul Wold2014-11-091-2/+3
| | | | | Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libcap: Upgrade to 2.24Saul Wold2014-11-093-50/+7
| | | | | | | | | | | Tarballs moved to kernel.org Deleted upstream'ed patch merged minimal .bb with .inc Check for security dir before moving it when pam is enabled. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* nss: Upgrade to 3.17Saul Wold2014-11-0615-1281/+9
| | | | | | | | CVE patches removed since they have been implemented upstream Rename patch dir (files) to generic PN name Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* acl: add acl dependency to acl-ptestRoss Burton2014-11-061-1/+1
| | | | | | | The acl test suite doesn't work without the acl binaries, so add an explicit dependency. Signed-off-by: Ross Burton <ross.burton@intel.com>
* libunistring: 0.9.3 -> 0.9.4Richard Purdie2014-11-054-124/+11
| | | | | | Drop two patches merged upstream. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* curl: Security Advisory - curl - CVE-2014-3620Chong Lu2014-11-052-0/+70
| | | | | | | | | libcurl wrongly allows cookies to be set for Top Level Domains (TLDs), thus making them apply broader than cookies are allowed. This can allow arbitrary sites to set cookies that then would get sent to a different and unrelated site or domain. Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
* curl: Security Advisory - curl - CVE-2014-3613Chong Lu2014-11-042-0/+270
| | | | | | | | | By not detecting and rejecting domain names for partial literal IP addresses properly when parsing received HTTP cookies, libcurl can be fooled to both sending cookies to wrong sites and into allowing arbitrary sites to set cookies for others. Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
* liburcu: revert ARM GCC blacklist commitJonathan Liu2014-10-242-0/+48
| | | | | | | | | | | This fixes the following error when building liburcu: "Your gcc version produces clobbered frame accesses" OE-Core is using a patched GCC 4.8.2 which is able to compile liburcu properly. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gnupg_1.4.7: add package config libusbKai Kang2014-10-181-0/+1
| | | | | | | | | | If build gnupg 1.4.7 after libusb-compat, it shows warning: WARNING: QA Issue: gnupg rdepends on libusb-compat, but it isn't a build dependency? [build-deps] Add package config libusb to fix it. Signed-off-by: Kai Kang <kai.kang@windriver.com>
* gnupg: CVE-2013-4242Kai Kang2014-10-182-0/+63
| | | | | | | | | | | | | GnuPG before 1.4.14, and Libgcrypt before 1.5.3 as used in GnuPG 2.0.x and possibly other products, allows local users to obtain private RSA keys via a cache side-channel attack involving the L3 cache, aka Flush+Reload. Patch from commit e2202ff2b704623efc6277fb5256e4e15bac5676 in git://git.gnupg.org/libgcrypt.git Signed-off-by: Yong Zhang <yong.zhang@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com>
* nss-myhostname: skip it when systemdRobert Yang2014-10-101-1/+4
| | | | | | | | | | Fixed error when systemd is in DISTRO_FEATURES: ERROR: The recipe systemd is trying to install files into a sharedarea when those files already exist. Those files and their manifestlocation are: /path/to/sysroots/qemux86/usr/lib/libnss_myhostname.so.2 Matched in manifest-qemux86-nss-myhostname.populate_sysroot Please verify which recipe should provide theabove files. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* boost: fix build when ${PARALLEL_MAKE} contains '-l'Enrico Scholz2014-10-101-10/+18
| | | | | | | | | | | The '-l' option which is valid for GNU make (--> limit by load) has a different meaning in bjam (--> limit maximum execution time) and will break very likely the build. Keep only the the '-l' option when passing PARALLEL_MAKE options to bjam. Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
* gnome-desktop-testing: Fix build on uclibcKhem Raj2014-10-102-1/+38
| | | | | | | [YOCTO #6577] Change-Id: Ia29fb963a7df4e77504993172f85851e0b540c7e Signed-off-by: Khem Raj <raj.khem@gmail.com>
* curl: add PACKAGECONFIG option to use libssh2Fabrice Coulon2014-10-101-2/+2
| | | | | | | | | | | The user can enable libssh2 via conf/local.conf or custom distro configuration, this will pull in libssh2, which is not used by default. For example, a curl_x.y.z.bbappend file containing the following line: PACKAGECONFIG += "libssh2" Signed-off-by: Fabrice Coulon <fabrice.coulon@axis.com> Signed-off-by: Olof Johansson <olof.johansson@axis.com>
* libassuan: fix for rebuildRobert Yang2014-10-101-1/+1
| | | | | | | | | | Fixed when rebuild: rm: cannot remove `/path/to/2.1.2-r0/libassuan-2.1.2/m4/*.m4': No such file or directory The files may not exist when rebuild. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* nss: nss.pc is not target specificSaul Wold2014-09-301-2/+4
| | | | | | | RPM4 requires an nss-native component Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* icu.inc: modify SPDX_S variableleimaohui2014-09-291-0/+1
| | | | | | Modify SPDX_S to the source tree of icu instead of ${S}. Signed-off-by: leimaohui <leimaohui@cn.fujitsu.com>
* db_6.0.30: modify SPDX_S variableleimaohui2014-09-291-0/+1
| | | | | | Modify SPDX_S to the source tree of db-6.0.30 instead of ${S}. Signed-off-by: leimaohui <leimaohui@cn.fujitsu.com>