summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
Commit message (Collapse)AuthorAgeFilesLines
* libffi: don't compile in mips16e modeAndré Draszik2016-07-011-0/+4
| | | | | | | | | | | libffi contains hand-written assembly which is not compatible with the MIPS16e mode. (From OE-Core rev: 27467ca354801aeb6d7e3a658cff3dda37db971a) Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gmp: don't compile in mips16e modeAndré Draszik2016-07-011-0/+4
| | | | | | | | | | | gmp contains hand-written assembly which is not compatible with the MIPS16e mode. (From OE-Core rev: 217729318b42ab378e1cc70db7726022a5837b49) Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* bash-completion: delete files util-linux providesChen Qi2016-07-011-1/+1
| | | | | | | | (From OE-Core rev: ae4e994b7a23ceeef00137110a35fbe0e509caec) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libcap: fix the libcap-native building failure on CentOS 6.7Roy Li2016-07-012-2/+35
| | | | | | | | (From OE-Core rev: a80656588a5122b0930a0d8a574c6633118f78d4) Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* pythonnative.bbclass, python3native.bbclass: export STAGING_INCDIR, ↵Alexander Kanavin2016-07-011-3/+0
| | | | | | | | | | | | | | | | | | | | | | | STAGING_LIBDIR, PYTHON variables We patch Python's distutils modules to access STAGING_INCDIR/LIBDIR, so when they are not set, scripts that utilize distutils (e.g. python-config) fail. Several recipes need to export those manually to prevent such failures, so let's do that in the class instead. PYTHON variable is exported because otherwise autotools' python.m4 macro will pick up its own internal default, which may not be the version that we want. glib recipe in particular was previously using Python 2.x during build due to python.m4 defaulting to it - now it's using Python 3.x, and so needs a small fix in deletion of *.pyc files. (From OE-Core rev: c1e0eb62f2d89b10b187016200018830b1c77945) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* vte: don't build test appJussi Kukkonen2016-07-011-1/+1
| | | | | | | | (From OE-Core rev: 23045bf89d9859d756310899052e9dd1aad302ce) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* at-spi2-atk: Upgrade 2.18.1 -> 2.20.1Jussi Kukkonen2016-07-011-2/+2
| | | | | | | | (From OE-Core rev: cc4cc96215007c69109064998521a87ceab0d771) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* at-spi2-core: Upgrade 2.18.3 -> 2.20.2Jussi Kukkonen2016-07-013-23/+78
| | | | | | | | | | Add systemd unit, patch in a configure flag to set the correct dir. (From OE-Core rev: 02cbcd7a94ff90d72443241915496d1f00345b69) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* atk: Upgrade 2.18.0 -> 2.20.0Jussi Kukkonen2016-07-011-3/+3
| | | | | | | | (From OE-Core rev: 8d379193edf59cc88fd173814cad6019714c5376) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libfm: switch to GTK3 versionMaxin B. John2016-06-151-2/+4
| | | | | | | | | | Build GTK3 version of libfm. (From OE-Core rev: ba925f5ada86bd36208027e3415e54ba0e5ec6b1) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* vte: Upgrade to 0.44.1Jussi Kukkonen2016-06-156-181/+57
| | | | | | | | | | | | | | | | | | * License change LGPL 2.0 -> LGPL 2.1+ * vte-termcap is no more * API break: current version seems to be parallel installable with old one, but I did not opt for that. * Add patch to avoid stack protection by default * Use libtool-cross: libtool adds "-nostdlib" when g++ is used, and this leads to a link failure on PIE builds: "undefined reference to __init_array_start". libtool-cross has a hack to avoid "-nostdlib" (From OE-Core rev: dc21182ada418cf3917ae8319494d219462c5bfd) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libgcrypt: upgrade to 1.7.0Hongxu Jia2016-06-155-61/+115
| | | | | | | | | | - Add fix-undefined-reference-to-pthread.patch to fix undefined reference to `pthread_create' (From OE-Core rev: f9ed35ec4aeca0a37e8b00a0b185abf1b87db0d1) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gnugp: upgrade to 2.1.12Hongxu Jia2016-06-151-2/+2
| | | | | | | (From OE-Core rev: 21078e8f5a2156b1a1f4f50d345508fb1c7e7e66) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libcap: 2.24 -> 2.25Robert Yang2016-06-151-3/+3
| | | | | | | | | | And fixed do_install: SBINDIR="${D}${sbindir}" -> SBINDIR="${sbindir}" (From OE-Core rev: 0ffcb59b700981a00c0e93e33cae5f720dc9a82b) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libbsd: 0.8.2 -> 0.8.3Robert Yang2016-06-151-3/+3
| | | | | | | | | The LIC_FILES_CHKSUM changed because a word changes: http -> https. (From OE-Core rev: 15f70441476b485dab2959113ec52c322e0db49a) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* curl: upgrade to 7.49.1Chen Qi2016-06-151-2/+2
| | | | | | | (From OE-Core rev: 53761f4f2d4b8463bf9f996a87ee0dc61e21a2d0) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gnutls: update 3.4.9 -> 3.4.11Andre McCurdy2016-06-121-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Version 3.4.10 (released 2016-03-03) ** libgnutls: Eliminated issues preventing buffers more than 2^32 bytes to be used with hashing functions. ** libgnutls: Corrected leaks and other issues in gnutls_x509_crt_list_import(). ** libgnutls: Fixes in DSA key handling for PKCS #11. Report and patches by Jan Vcelak. ** libgnutls: Several fixes to prevent relying on undefined behavior of C (found with libubsan). * Version 3.4.11 (released 2016-04-11) ** libgnutls: Fixes in gnutls_record_get/set_state() with DTLS. Reported by Fridolin Pokorny. ** libgnutls: Fixes in DSA key generation under PKCS #11. Report and patches by Jan Vcelak. ** libgnutls: Corrected behavior of ALPN extension parsing during session resumption. Report and patches by Yuriy M. Kaminskiy. ** libgnutls: Corrected regression (since 3.4.0) in gnutls_server_name_set() which caused it not to accept non-null-terminated hostnames. Reported by Tim Ruehsen. ** libgnutls: Corrected printing of the IP Adress name constraints. ** ocsptool: use HTTP/1.0 for requests. This avoids issue with servers serving chunk encoding which ocsptool doesn't support. Reported by Thomas Klute. ** certtool: do not require a CA for OCSP signing tag. This follows the recommendations in RFC6960 in 4.2.2.2 which allow a CA to delegate OCSP signing to another certificate without requiring it to be a CA. Reported by Thomas Klute. (From OE-Core rev: a41d0ba222b5f0542cb39fe0dcaae1b72cd47e35) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* bash-completion: fix upstream version checkAlexander Kanavin2016-06-121-0/+1
| | | | | | | | (From OE-Core rev: 8093cc5649b8a827f9ebb70858cfc1d0f9f264b2) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* db: add RECIPE_NO_UPDATE_REASONMaxin B. John2016-06-071-0/+1
| | | | | | | | | db-6.2.23 does not work with RPM-5.x due to changes in locking semantics (From OE-Core rev: 8ea6be55b795ae5306606f7d4cdacdf3c2afa5ae) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libxslt: update to 1.1.29Alexander Kanavin2016-06-043-53/+31
| | | | | | | | | | Drop upstreamed CVE-2015-7995.patch Rebase pkgconfig.patch (From OE-Core rev: f83217590d3157c1db502ddb27b94fe1c704185b) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libksba: update to 1.3.4Alexander Kanavin2016-06-041-2/+2
| | | | | | | (From OE-Core rev: eeb5b00159a3cb0404b0ff97baa9563734f44b79) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* iso-codes: update to 3.68Alexander Kanavin2016-06-041-3/+3
| | | | | | | | | License file has been renamed, but still contains LGPLv2.1 (From OE-Core rev: f8a0a8f75c64cf69bd94664c4b3ffef368830cc2) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* icu: update to 57.1Alexander Kanavin2016-06-042-28/+3
| | | | | | | | | | Point to the actual license file in the recipe. Drop icu-release-56-1-flagparser-fix.patch, merged upstream. (From OE-Core rev: 91d230dfbfd8acaea16978ee75c7a75549ffde86) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* boost: update to 1.61.0Alexander Kanavin2016-06-044-48/+2
| | | | | | | | | 0001-Do-not-qualify-fenv.h-names-that-might-be-macros.patch has been merged upstream. (From OE-Core rev: 25d4129bab9f6abeecbfec6b69612e387851bfe3) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdbm: upgrade to 1.12Alexander Kanavin2016-06-041-2/+2
| | | | | | | (From OE-Core rev: 81fa61c94a99100daf2955bc699aaa213d35af94) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ca-certificates: add dependency for native/nativesdk on openssl-nativePaul Eggleton2016-06-031-1/+2
| | | | | | | | | | | | When running update-ca-certificates on the build host, as we do during do_install for ca-certificates-native (and nativesdk-ca-certificates), as of OE-Core commit cea46e7b8d9463306779301fa97f651d750f380f we now need openssl-native so it can run c_rehash. (From OE-Core rev: 523c99a2f12c20ce7bfa7755609f2c860dda6717) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libcap-ng: move to Python 3Alexander Kanavin2016-06-031-5/+7
| | | | | | | (From OE-Core rev: 671a8e58aba0a01ad8571995dadbf569706df954) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ca-certificates: Add openssl as a runtime dependencyOtavio Salvador2016-05-301-0/+2
| | | | | | | | | | | | The update-ca-certificates script uses the c_rehash utility which is installed by openssl. Add openssl as a runtime dependency to fulfill the utility requirement. (From OE-Core rev: a90ba07812444ebac93cd535d11dd54994897bfd) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* liburcu: upgrade to 0.9.2Alexander Kanavin2016-05-301-2/+2
| | | | | | | | (From OE-Core rev: f3add5f539b4df5adad1153baa8f91930418b0d4) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libgpg-error: Upgrade 1.21 -> 1.22Jussi Kukkonen2016-05-302-51/+4
| | | | | | | | | | | License checksum changes are not license changes. Remove a patch that's in upstream now. (From OE-Core rev: 3493bda7c10ba12a596ba0224eca646b93ea9181) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gnupg.org-hosted recipes: Change SRC_URI to https siteJussi Kukkonen2016-05-309-9/+17
| | | | | | | | | | | | | | | | | | | https version seems more reliable and in an informal test fetching all gnupg recipes now takes <20% of the time it used to. Define GNUPG_MIRROR in bitbake.conf so future tweaks to this are easier. Replace some slower mirrors with the official ftp site and another from gnupg.org mirror list. Set UPSTREAM_CHECK_URI in all recipes that need it to "https://gnupg.org/download/index.html" as the directory listings are not up-to-date. (From OE-Core rev: dfc9178e2f2b6873ca497d981e308e00d15280b5) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libevdev: Upgrade 1.4.6 -> 1.5.1Jussi Kukkonen2016-05-301-2/+2
| | | | | | | | (From OE-Core rev: cab454a22a877cf6226b210de23e10b0a33b0acc) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* argp-standalone: set SUMMARY instead of DESCRIPTIONPaul Eggleton2016-05-301-1/+1
| | | | | | | | | | | Short descriptions should go into SUMMARY (DESCRIPTION will get the same value if not set. (From OE-Core rev: 82cf96ad1a1e27324a281ca952e11d5b1ffd611e) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sqlite3: update to 3.13.0Maxin B. John2016-05-251-2/+2
| | | | | | | | | 3.12.2 -> 3.13.0 (From OE-Core rev: eb1ebea41566d233489c43e73d5f7100ab3e538c) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* ca-certificates: Use c_rehash utilityOtavio Salvador2016-05-252-47/+0
| | | | | | | | | | As now the c_rehash utility is available, we can use it. This removes the patch to disable its usage allowing for a standard SSL behaviour. (From OE-Core rev: cea46e7b8d9463306779301fa97f651d750f380f) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libsoup-2.4: provide PACKAGECONFIG for gssapiMaxin B. John2016-05-221-0/+1
| | | | | | | | | | | | | | | | | Fixes this build error: | ../../libsoup-2.54.1/libsoup/soup-auth-negotiate.c:16:27: fatal error: gssapi/gssapi.h: No such file or directory | compilation terminated. | Makefile:1166: recipe for target 'libsoup_2_4_la-soup-auth-negotiate.lo' failed | make[3]: *** [libsoup_2_4_la-soup-auth-negotiate.lo] Error 1 (From OE-Core rev: 378608a99560c7720189ca6ba4158e10cbe42abf) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* acl.inc, run-ptest: improve ptest functionality on limited rootfsPeter Seebach2016-05-203-5/+87
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | ACL's ptest has a handful of failure modes which can be triggered by a restrictive or small system. First, the ptest requires that daemon be in the bin group, which run-ptest attempts to do using gpasswd, but gpasswd is part of shadow, and oe-core removes shadow when it doesn't think shadow will be needed. Even if, say, a package has RDEPENDS on it. Whoops. So we manually sed the group file. This will probably work. Second, the filesystem used for the test has to support ACLs, so we create a dummy ext3 filesystem and use that. Third, the root/permissions test relies on the assumption that "mkdir d" produces a directory which non-root users can access, but in a secure product which defaults to umask 077, this doesn't work. (That fix has been separately reported to upstream acl through their bug report form.) (This may prevent the test from running without mkfs.ext3, but it allows the test to run on targets where root doesn't have ACL support. Tradeoffs, tradeoffs everywhere.) (From OE-Core rev: 0f1054e7db74bb4a196e00773915d7997b55bdf2) Signed-off-by: Peter Seebach <peter.seebach@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libproxy: update to version 0.4.13Maxin B. John2016-05-172-44/+7
| | | | | | | | | | | 1. libproxy moved from google-code to github 2. Remove upstreamed patch: a) 0001-test-Include-sys-select.h-for-select.patch (From OE-Core rev: 34e2db8ea7eb51be8549f343d6ff19cdd7db3ff1) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libsoup-2.4: Upgrade 2.52.2 -> 2.54.1Jussi Kukkonen2016-05-171-2/+2
| | | | | | | (From OE-Core rev: 69803cf99577c6eefc8074aa40be85cefb154c4b) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* bmap-tools: initial commit, version 3.2Ed Bartosh2016-05-141-0/+24
| | | | | | | | | | | | | | | | | Bmap-tools - tools to generate block map (AKA bmap) and flash images using bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file and copying files using the block map. The idea is that large file containing unused blocks, like raw system image files, can be copied or flashed a lot faster with bmaptool than with traditional tools like "dd" or "cp". [YOCTO #9414] (From OE-Core rev: d18429a5b899de95fa2896aa46ce6c4a04739be5) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* mpfr: Upgrade to 3.1.4Khem Raj2016-05-132-3/+2
| | | | | | | (From OE-Core rev: 8f8aebc59df181071245cfeb6eb4a3efaf65c597) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libunwind: Add a confgure option for testsKhem Raj2016-05-132-2/+72
| | | | | | | | | | | Tests dont compile on musl due to its use of {get|set}context APIs, adding this option to disable tests helps it to compile (From OE-Core rev: 026f14c1353b599546cec24b6b779ff872ff890e) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libunwind: Upgrade to 1.2rc1+Khem Raj2016-05-132-67/+0
| | | | | | | | | | | | This helps in compiling with gcc6 drop patches backported to 1.1 remove musl conditional patches, they should work on glibc too now (From OE-Core rev: f07c2430903601e9b4462eb09e89a341d5f8f4af) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libunwind: Upgrade to 1.2rc1+Khem Raj2016-05-1312-2776/+37
| | | | | | | | | | | | This helps in compiling with gcc6 drop patches backported to 1.1 remove musl conditional patches, they should work on glibc too now (From OE-Core rev: d164b4dbcbba4dd7db4c4257e6cd876026c2e7eb) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* nss: Upgrade to 3.23Khem Raj2016-05-131-4/+4
| | | | | | | | | | | | | | | | | | | | | | | Disable Werror on native builds. This helps in building nss-native on build hosts which have gcc < 4.9 eg. ubuntu 14.04 The real issue is that we use headers from native staging sysroot and it has the updated glibc headers which then ends up with errors e.g. | In function 'memset', | inlined from 'sec_PKCS7Encrypt' at p7local.c:715:14: | /usr/include/x86_64-linux-gnu/bits/string3.h:81:30: error: call to '__warn_memset_zero_len' declared with attribute warning: memset used with constant zero length parameter; this could be due to transposed parameters [-Werror] | __warn_memset_zero_len (); | ^ | cc1: all warnings being treated as errors | make[2]: *** [Linux3.4_x86_64_glibc_PTH_64_OPT.OBJ/p7local.o] Error 1 (From OE-Core rev: e69feac4066c8c27b50c88daf9ebaa27a5c54646) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* lzop: Fix build with gcc-6Khem Raj2016-05-132-3/+40
| | | | | | | (From OE-Core rev: aaab0e290ec7c4fb09a46a15d72d6aec6dedc832) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libpcre: Fix CVE-2016-3191Ismo Puustinen2016-05-112-0/+175
| | | | | | | | | | | | | | Fix workspace overflow for (*ACCEPT) with deeply nested parentheses. The patch is from libpcre version control at http://vcs.pcre.org/pcre?view=revision&revision=1631 with the ChangeLog part removed. Original author is Philip Hazel. (From OE-Core rev: 386534f968f4da376ba7778b5d436bad4ce8355b) Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sqlite3: upgrade to 3.12.2Maxin B. John2016-05-113-72/+9
| | | | | | | | | | | | | 3.11.0 -> 3.12.2 Remove upstreamed patch: 1. fix-disable-static-shell.patch (From OE-Core rev: 1b0628f86aaebcd786f1646a8f6f41de7fb80acc) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libtasn1: upgrade to 4.8Maxin B. John2016-05-111-2/+2
| | | | | | | | | | 4.7 -> 4.8 (From OE-Core rev: 5bf69b1253ae82e85b1d550ce00d0708ee3c016b) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* popt: fix dependencies and QA IssueMaxin B. John2016-05-061-0/+2
| | | | | | | | | | | | | | Fix the following QA warning: WARNING: popt-1.16-r3 do_package_qa: QA Issue: popt rdepends on libiconv, but it isn't a build dependency, missing libiconv in DEPENDS or PACKAGECONFIG? [build-deps] (From OE-Core rev: 08aeb5a9e0067e2e9e0fba8614409102e5a0a00e) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>