summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2011-11-30 16:45:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 14:53:33 +0000
commit0b30e122e40472f5f1609cd9a513e6c4d198ac35 (patch)
treeec88306aae417abdd845ec0387f03d75b83d4af1
parent4450aa5f0f757a3694db6123f6afe57a833ae986 (diff)
downloadopenembedded-core-0b30e122e40472f5f1609cd9a513e6c4d198ac35.tar.gz
autoconf: Extend to provide nativesdk recipe
As the same reason with automake, extend autoconf to provide nativesdk recipe too. This patch was only used for autoconf that running on target: * path_prog_fixes.patch: replace '@PERL@' with '@bindir@/env perl' It's unavailable for autoconf-native and autoconf-nativesdk, so exclude it for those two recipes. (From OE-Core rev: a16cf1b67f6559b182e6bb31abc1371162b04428) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Joshua Lock <josh@linux.intel.com>
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.68.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.68.bb b/meta/recipes-devtools/autoconf/autoconf_2.68.bb
index c6209a37eb..f9bf7b47eb 100644
--- a/meta/recipes-devtools/autoconf/autoconf_2.68.bb
+++ b/meta/recipes-devtools/autoconf/autoconf_2.68.bb
@@ -1,6 +1,6 @@
require autoconf.inc
-PR = "r2"
+PR = "r3"
PARALLEL_MAKE = ""
@@ -14,7 +14,7 @@ SRC_URI += "file://autoreconf-include.patch \
file://autoreconf-foreign.patch \
file://autoreconf-gnuconfigize.patch \
file://autoheader-nonfatal-warnings.patch \
- ${@['file://path_prog_fixes.patch', ''][bb.data.inherits_class('native', d)]} \
+ ${@['file://path_prog_fixes.patch', ''][bb.data.inherits_class('native', d) or bb.data.inherits_class('nativesdk', d)]} \
file://config_site.patch \
file://remove-usr-local-lib-from-m4.patch \
"
@@ -25,6 +25,12 @@ SRC_URI[sha256sum] = "c491fb273fd6d4ca925e26ceed3d177920233c76d542b150ff35e57145
DEPENDS_virtclass-native = "m4-native gnu-config-native"
RDEPENDS_${PN}_virtclass-native = "m4-native gnu-config-native"
+DEPENDS_virtclass-nativesdk = "m4-nativesdk gnu-config-nativesdk"
+RDEPENDS_${PN}_virtclass-nativesdk = "m4-nativesdk gnu-config-nativesdk"
+
SRC_URI_append_virtclass-native = " file://fix_path_xtra.patch"
-BBCLASSEXTEND = "native"
+EXTRA_OECONF += "ac_cv_path_M4=m4"
+
+BBCLASSEXTEND = "native nativesdk"
+