summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2020-05-11 21:28:06 +0200
committerSteve Sakoman <steve@sakoman.com>2020-05-14 06:33:16 -1000
commit5bfdb6bfbd6f1de10d415228e5a5ebe01a623e2a (patch)
tree59e48d7a2880eb551ede3b25980f0c37d791de59
parent1038195fe9823c93cf20e2d256865171e0c915c4 (diff)
downloadopenembedded-core-5bfdb6bfbd6f1de10d415228e5a5ebe01a623e2a.tar.gz
file: add PACKAGECONFIG for auto options
A few options of file configure are set to auto, which can lead to unpredictable effects when something in the sysroot does provide things that satisfy the autotools checks. In the worst case this will lead to package-qa failures as libraries are not set in RDEPENDS but configured for the tool. To mitigate changes of accidental configure set explicit options via newly introduced PACKAGECONFIG variables for bzip, lzma and zlib support, where the default is just zlib, as it was before Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/file/file_5.38.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-devtools/file/file_5.38.bb b/meta/recipes-devtools/file/file_5.38.bb
index b8f09107e8..f5ad568936 100644
--- a/meta/recipes-devtools/file/file_5.38.bb
+++ b/meta/recipes-devtools/file/file_5.38.bb
@@ -8,8 +8,8 @@ SECTION = "console/utils"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
-DEPENDS = "zlib file-replacement-native"
-DEPENDS_class-native = "zlib-native"
+DEPENDS = "file-replacement-native"
+DEPENDS_class-native = ""
SRC_URI = "git://github.com/file/file.git"
@@ -18,6 +18,12 @@ S = "${WORKDIR}/git"
inherit autotools update-alternatives
+PACKAGECONFIG ??= "zlib"
+PACKAGECONFIG_class-native ??= "zlib"
+PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
+PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
+PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
+
EXTRA_OECONF += "--disable-libseccomp"
ALTERNATIVE_${PN} = "file"