summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-27 13:51:07 -0700
committerSteve Sakoman <steve@sakoman.com>2020-05-30 12:12:42 -1000
commit8a7da39c04fbab1280c464f39a791e4fbd1e7da9 (patch)
treea7397975f6e7c2ea9b0c5a7b274aeec32c4878df
parent9c2efe41d5d894094552c4bbc4180675a5aac751 (diff)
downloadopenembedded-core-8a7da39c04fbab1280c464f39a791e4fbd1e7da9.tar.gz
make-mod-scripts: Fix a rare build race condition
There is a build break which rarely happens but is seen often enough with 4.1 kernel based builds /bin/sh: 1: scripts/basic/fixdep: Permission denied scripts/Makefile.host:124: recipe for target 'scripts/dtc/srcpos.o' failed make[3]: *** [scripts/dtc/srcpos.o] Error 126 this patch sequences the build targets so it can work reliably with different kernel versions Divide the target into scripts_basic scripts is not strictly necessary and was simply what was used for testing on kernel 4.1, which is quite an old kernel perhaps just using scripts is sufficient, but it is not tested to not known will cause the build race as seen above. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 55ac6e2d251287419138931aa0d0894cf1267787) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
index 0be1422a24..c7edb20ee4 100644
--- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
+++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
@@ -23,7 +23,8 @@ EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="
#
do_configure() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
- -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
-
+ for t in prepare scripts_basic scripts; do
+ oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
+ -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
+ done
}