summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-12-26 16:50:02 -0500
committerSteve Sakoman <steve@sakoman.com>2021-07-20 06:36:58 -1000
commit9ae339ace9274be71bfd3b5e5da64dceac9fa963 (patch)
treeced4398505a4fb4bbbe3915d9fe9480631ab9df6
parent6bee4dbf3761e372bd9b40555dc776464e1ced59 (diff)
downloadopenembedded-core-9ae339ace9274be71bfd3b5e5da64dceac9fa963.tar.gz
kernel-devsrc: fix 32bit ARM devsrc buildsyocto-3.1.102020-04.10-dunfell2020-04.10
As a follow up to commit: 0fc66a0b64953 [kernel: provide module.lds for out of tree builds in v5.10+], we must not only copy module.lds from its new location, we have to not error when it isn't found in the old location. With this tweak, we have coverage on all supported arches for the new location of module.lds, and backwards compatibility through kernel versions. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit cb940d8af359fa370254bd4c2b36ba26708bb54b) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 951e7635cc..887e1e2430 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -177,7 +177,7 @@ do_install() {
cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
fi
- cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
+ cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
fi
if [ -d arch/${ARCH}/include ]; then