summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-06-04 16:13:39 +0800
committerSteve Sakoman <steve@sakoman.com>2021-11-08 16:25:10 -1000
commitba5562d34653fa6b5819dbc8ca80a42167c38c96 (patch)
treec7b8852d63709cc63ddddad7723ca3a6e4c139e3
parent5ebea40c2236900a11b6025b53b4728eb08e5464 (diff)
downloadopenembedded-core-ba5562d34653fa6b5819dbc8ca80a42167c38c96.tar.gz
python3-magic: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import magic [snip] ModuleNotFoundError: No module named 'ctypes' ModuleNotFoundError: No module named 'tempfile' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 115791844124bdddfbaec9d75bb887ef35c41f20) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.15.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.15.bb b/meta/recipes-devtools/python/python3-magic_0.4.15.bb
index 698016ba4c..09b24fb7f3 100644
--- a/meta/recipes-devtools/python/python3-magic_0.4.15.bb
+++ b/meta/recipes-devtools/python/python3-magic_0.4.15.bb
@@ -14,6 +14,9 @@ inherit pypi setuptools3
SRC_URI[md5sum] = "e384c95a47218f66c6501cd6dd45ff59"
SRC_URI[sha256sum] = "f3765c0f582d2dfc72c15f3b5a82aecfae9498bd29ca840d72f37d7bd38bfcd5"
-RDEPENDS_${PN} += "file"
+RDEPENDS_${PN} += "file \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-shell"
BBCLASSEXTEND = "native"