aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-09-27 12:41:44 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-29 16:42:19 +0100
commit2b181178207ab69b589f4fd0068670ccf23c5aee (patch)
treeda3ac5cfb52a2d7c6e9ba63fd48b24c49019253c
parent22cbcd964fceb43c89142be77db8950425b4303e (diff)
downloadopenembedded-core-2b181178207ab69b589f4fd0068670ccf23c5aee.tar.gz
bzip2: use new batch update-alternatives feature
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.5.bb25
1 files changed, 5 insertions, 20 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.5.bb b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
index c6339c0676..1e858f4b11 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.bzip.org/"
SECTION = "console/utils"
LICENSE = "bzip2"
LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
file://configure.ac \
@@ -11,7 +11,10 @@ SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
-inherit autotools
+inherit autotools update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_LINKS = "${bindir}/bunzip2 ${bindir}/bzcat"
do_configure_prepend () {
cp ${WORKDIR}/configure.ac ${S}/
@@ -19,23 +22,5 @@ do_configure_prepend () {
cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
}
-do_install_append () {
- if [ "${BUILD_ARCH}" != "${HOST_ARCH}" ]; then
- mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
- mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
- fi
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
- update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
-}
-
-
-pkg_prerm_${PN} () {
- update-alternatives --remove bunzip2 bunzip2.${PN}
- update-alternatives --remove bzcat bzcat.${PN}
-}
-
PROVIDES_append_virtclass-native = " bzip2-full-native"
BBCLASSEXTEND = "native"