summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2019-01-15 01:49:06 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-15 23:35:15 +0000
commit42d52a279a75c94c4deba50b448dd3b6b2ac75df (patch)
tree8da322e6c01a8306e16e0d05408187a15bbe5092
parent63ae444b1dba65ccb1693648914becabd65ac30d (diff)
downloadopenembedded-core-42d52a279a75c94c4deba50b448dd3b6b2ac75df.tar.gz
systemd: Correct a conditional add to SYSTEMD_PACKAGES
The code conditionally adding ${PN}-journal-remote to SYSTEMD_PACKAGE checked PACKAGECONFIG for an empty string rather than 'microhttpd'... Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_239.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_239.bb b/meta/recipes-core/systemd/systemd_239.bb
index 87b0642c26..c146897508 100644
--- a/meta/recipes-core/systemd/systemd_239.bb
+++ b/meta/recipes-core/systemd/systemd_239.bb
@@ -337,8 +337,8 @@ DESCRIPTION_${PN}-journal-remote = "systemd-journal-remote is a command to recei
SYSTEMD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'binfmt', '${PN}-binfmt', '', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-gatewayd', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-remote', '', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'journal-upload', '${PN}-journal-upload', '', d)} \
- ${@bb.utils.contains('PACKAGECONFIG', '', '${PN}-journal-remote', '', d)} \
"
SYSTEMD_SERVICE_${PN}-binfmt = "systemd-binfmt.service"