summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-16 12:39:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-17 13:41:56 +0100
commit5d82adcbc2326d8abc0039388578d730906b3e58 (patch)
treeb2d24c9a40686c83e0b448201b2556d15a808117
parent6f0d401a508b55f30c11eec8cd875524eb75c40a (diff)
downloadopenembedded-core-5d82adcbc2326d8abc0039388578d730906b3e58.tar.gz
gcompat: Create symlinks to glibc ldso locations
This ensures the glibc based binaries can find it in right place Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/musl/gcompat_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/recipes-core/musl/gcompat_git.bb b/meta/recipes-core/musl/gcompat_git.bb
index e1ae052c44..863ba8dbf0 100644
--- a/meta/recipes-core/musl/gcompat_git.bb
+++ b/meta/recipes-core/musl/gcompat_git.bb
@@ -14,14 +14,16 @@ SRCREV = "af5a49e489fdc04b9cf02547650d7aeaccd43793"
S = "${WORKDIR}/git"
-inherit pkgconfig linuxloader
+inherit pkgconfig linuxloader siteinfo
DEPENDS += "musl-obstack"
GLIBC_LDSO = "${@get_glibc_loader(d)}"
MUSL_LDSO = "${@get_musl_loader(d)}"
-EXTRA_OEMAKE = "LINKER_PATH=${MUSL_LDSO} LOADER_NAME=`basename ${@get_glibc_loader(d)}`"
+EXTRA_OEMAKE = "LINKER_PATH=${MUSL_LDSO} \
+ LOADER_NAME=`basename ${GLIBC_LDSO}` \
+ "
do_configure () {
:
@@ -33,8 +35,16 @@ do_compile () {
do_install () {
oe_runmake install 'DESTDIR=${D}'
+ if [ "${SITEINFO_BITS}" = "64" ]; then
+ install -d ${D}/lib64
+ lnr ${D}${GLIBC_LDSO} ${D}/lib64/`basename ${GLIBC_LDSO}`
+ fi
}
+FILES_${PN} += "/lib64"
+
+INSANE_SKIP_${PN} = "libdir"
+
RPROVIDES_${PN} += "musl-glibc-compat"
#
# We will skip parsing for non-musl systems