summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-06-13 15:17:01 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-14 22:47:43 +0100
commit76a7f0d60f5dc38da15f21720cb97bf761562b44 (patch)
tree982560b34a78050205b78eb3b8561b1133450fcf
parent785bb108ceb9dc137ec8d75d887b6a3869cbfb9c (diff)
downloadopenembedded-core-76a7f0d60f5dc38da15f21720cb97bf761562b44.tar.gz
opkg-utils: upgrade to version 0.4.1
- Drop 0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch - Drop 0001-opkg-list-fields-fix-to-print-the-fields-again.patch Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch33
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch41
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.1.bb (renamed from meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb)6
3 files changed, 2 insertions, 78 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch
deleted file mode 100644
index 6c058c71d7..0000000000
--- a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 42afc1f652d28dce3c5b9915d0cd3087a144e445 Mon Sep 17 00:00:00 2001
-From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-Date: Mon, 18 Feb 2019 11:25:43 -0600
-Subject: [PATCH] opkg-build: do not set mtime on data.tar.X
-
-Opkg should make sure the binaries it creates are created in a
-repoducibe way, but it shouldn't modify the mtime of the binaries it
-consumes. Doing so has side effects, for exmaple, Python pyc files are
-invalidated.
-
-Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-
-Upstream-Status: Submitted
----
- opkg-build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/opkg-build b/opkg-build
-index 13782ee..363cd01 100755
---- a/opkg-build
-+++ b/opkg-build
-@@ -301,7 +301,7 @@ build_date="${SOURCE_DATE_EPOCH:-$(date +%s)}"
-
- ( cd $pkg_dir/$CONTROL && find . -type f > $tmp_dir/control_list )
- ( cd $pkg_dir && find . -path ./$CONTROL -prune -o -print > $tmp_dir/file_list )
--( cd $pkg_dir && tar $ogargs $tsortargs --no-recursion --mtime=@$build_date -c $tarformat -T $tmp_dir/file_list | $compressor $compressorargs > $tmp_dir/data.tar.$cext )
-+( cd $pkg_dir && tar $ogargs $tsortargs --no-recursion -c $tarformat -T $tmp_dir/file_list | $compressor $compressorargs > $tmp_dir/data.tar.$cext )
- ( cd $pkg_dir/$CONTROL && tar $ogargs $tsortargs --no-recursion --mtime=@$build_date -c $tarformat -T $tmp_dir/control_list | gzip $zipargs > $tmp_dir/control.tar.gz )
- rm $tmp_dir/file_list
- rm $tmp_dir/control_list
---
-2.20.1
-
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch
deleted file mode 100644
index deaf561d1e..0000000000
--- a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From df675c91f4b33490f0fa831b11162bdb0e2ff550 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Thu, 23 May 2019 20:50:45 +0000
-Subject: [PATCH] opkg-list-fields: fix to print the fields again
-
-* printing opkg.Package directly doesn't return anything useful now
- <opkg.Package object at 0x7fd49e9f2780>
-
-* we need to call Package.print() function and specify which checksums
- to print, we can include both md5 and sha256 for opkg-list-fields
-
-* it was changed in this commit:
- commit 601d691dd80ef494aef069017edc5bf80aa883a1
- Author: Alejandro del Castillo <alejandro.delcastillo@ni.com>
- Date: Wed Dec 19 11:40:15 2018 -0600
-
- opkg-make-index: add sha256sum support
-
- which replaced the modified __str__ function with print(self, checksum)
-
-Upstream-Status: Backport [http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/commit/?id=5163a74a59d54b2a8374414435ece9d542dbd5e2]
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- opkg-list-fields | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/opkg-list-fields b/opkg-list-fields
-index c14a90f..8a5a588 100755
---- a/opkg-list-fields
-+++ b/opkg-list-fields
-@@ -11,5 +11,4 @@ def usage():
- if (len(sys.argv) < 2):
- usage()
-
--print(opkg.Package(sys.argv[1]))
--
-+print(opkg.Package(sys.argv[1]).print(('md5','sha256')))
---
-2.17.1
-
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.1.bb
index b2fb760267..4be7b16d8a 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.1.bb
@@ -9,14 +9,12 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
- file://0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch \
- file://0001-opkg-list-fields-fix-to-print-the-fields-again.patch \
"
UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
-SRC_URI[md5sum] = "6e1c2eae96239520a8eb3d05372773ea"
-SRC_URI[sha256sum] = "8153f4e5dadde422d35feaf86bf595266af9d0037389bc418fa87feb0437efb3"
+SRC_URI[md5sum] = "8c140f835b694a0c27cfb23d2426a02b"
+SRC_URI[sha256sum] = "9ea9efdd9fe13661ad251e3a2860c1c93045adcfaa6659c3e86d9748ecda3b6e"
TARGET_CC_ARCH += "${LDFLAGS}"