summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-09-14 12:09:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-21 08:15:19 -0700
commit80dae6218efd25c92b9c43360e0846bb0af56c7e (patch)
tree3014003d1a4b10bc6b60cf8de4113cffff884d16
parent1c67c2146e3644a26367a32885d27a4378f17ac6 (diff)
downloadopenembedded-core-80dae6218efd25c92b9c43360e0846bb0af56c7e.tar.gz
python3: respect package order in manifest
Don't sort the manifest when using it to generate packaging rules, so ordering can be used to have complex packaging rules. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 605ea6abfe..6085e36b7d 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -252,7 +252,7 @@ RPROVIDES_${PN} += "${PN}-modules"
INCLUDE_PYCS ?= "1"
python(){
- import json
+ import collections, json
filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
# This python changes the datastore based on the contents of a file, so mark
@@ -260,7 +260,7 @@ python(){
bb.parse.mark_dependency(d, filename)
with open(filename) as manifest_file:
- python_manifest=json.load(manifest_file)
+ python_manifest=json.load(manifest_file, object_pairs_hook=collections.OrderedDict)
include_pycs = d.getVar('INCLUDE_PYCS')
@@ -294,8 +294,6 @@ python(){
d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
- # We need to ensure staticdev packages match for files first so we sort in reverse
- newpackages.sort(reverse=True)
# Prepending so to avoid python-misc getting everything
packages = newpackages + packages
d.setVar('PACKAGES', ' '.join(packages))