summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-06-19 11:58:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-21 11:09:34 +0100
commit85b5b9a3f793f66bd396daa585d8693e13c11b08 (patch)
tree5851cb4f39057c4f3d9de3e9e218ead3ded1f167
parentea707e8726cd7012d101d02e69503b7c98bdaf3e (diff)
downloadopenembedded-core-85b5b9a3f793f66bd396daa585d8693e13c11b08.tar.gz
glibc: do not enable memory tagging on aarch64 just yet
Sadly, it seems to break copy-on-write as reported here: https://lists.openembedded.org/g/openembedded-core/message/153082 (From OE-Core rev: 6891217346128cf529c15192defa096378fc5091) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-core/glibc/glibc_2.33.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.33.bb b/meta/recipes-core/glibc/glibc_2.33.bb
index b70cd0978a..caa2e2ae18 100644
--- a/meta/recipes-core/glibc/glibc_2.33.bb
+++ b/meta/recipes-core/glibc/glibc_2.33.bb
@@ -90,10 +90,10 @@ EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
EXTRA_OECONF_append_x86 = " --enable-cet"
EXTRA_OECONF_append_x86-64 = " --enable-cet"
-EXTRA_OECONF_append_aarch64 = " --enable-memory-tagging"
PACKAGECONFIG ??= "nscd"
PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
+PACKAGECONFIG[memory-tagging] = "--enable-memory-tagging,--disable-memory-tagging"
do_patch_append() {
bb.build.exec_func('do_fix_readlib_c', d)