aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-20 11:20:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 17:07:18 +0000
commit264d276de62e3ea0c9b546d2f0b5d555a926bee7 (patch)
treea66a739c28c703acfae35f4e6873dc5f94caa508
parent60445afe0f1a4dbf490fe2d43f6845db7968c88a (diff)
downloadopenembedded-core-264d276de62e3ea0c9b546d2f0b5d555a926bee7.tar.gz
gnu-efi: Fix build with gcc7
(From OE-Core rev: a253743f3e3badadb0afe90a277dd4d252b32c6c) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Fixup for mporty context Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi/0001-Mark-our-explicit-fall-through-so-Wextra-will-work-i.patch34
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi/0001-Mark-our-explicit-fall-through-so-Wextra-will-work-i.patch b/meta/recipes-bsp/gnu-efi/gnu-efi/0001-Mark-our-explicit-fall-through-so-Wextra-will-work-i.patch
new file mode 100644
index 0000000000..d0aeb2d560
--- /dev/null
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi/0001-Mark-our-explicit-fall-through-so-Wextra-will-work-i.patch
@@ -0,0 +1,34 @@
+From 676a8a9001f06808b4dbe0a545d76b5d9a8ebf48 Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Thu, 2 Feb 2017 13:51:27 -0500
+Subject: [PATCH] Mark our explicit fall through so -Wextra will work in gcc 7
+
+gcc 7 introduces detection of fall-through behavior in switch/case
+statements, and will warn if -Wimplicit-fallthrough is present and there
+is no comment stating that the fall-through is intentional. This is
+also triggered by -Wextra, as it enables -Wimplicit-fallthrough=1.
+
+This patch adds the comment in the one place we use fall-through.
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+---
+Upstream-Status: Pending
+
+ lib/print.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/print.c b/lib/print.c
+index b8a9d38..cb732f0 100644
+--- a/lib/print.c
++++ b/lib/print.c
+@@ -1131,6 +1131,7 @@ Returns:
+ case 'X':
+ Item.Width = Item.Long ? 16 : 8;
+ Item.Pad = '0';
++ /* falls through */
+ case 'x':
+ ValueToHex (
+ Item.Scratch,
+--
+2.12.2
+
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
index c6a9714d35..313b13e7d1 100644
--- a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
@@ -17,7 +17,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2 \
file://lib-Makefile-fix-parallel-issue.patch \
file://gcc46-compatibility.patch \
file://aarch64-initplat.c-fix-const-qualifier.patch \
- "
+ file://0001-Mark-our-explicit-fall-through-so-Wextra-will-work-i.patch \
+ "
SRC_URI[md5sum] = "612e0f327f31c4b8468ef55f4eeb9649"
SRC_URI[sha256sum] = "51a00428c3ccb96db24089ed8394843c4f83cf8f42c6a4dfddb4b7c23f2bf8af"