aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:19:59 +0100
commit73ee5587a46751ed39a181b3ff2a12d4a3086c21 (patch)
treea5cf72fce577e567d1dfa357fe772825b8134d00
parentb93a9dadc9a2754d4e33929bda8dba46dd20b694 (diff)
downloadopenembedded-core-73ee5587a46751ed39a181b3ff2a12d4a3086c21.tar.gz
ubootchart: use variables instead of hardcoded paths
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/ubootchart/ubootchart_svn.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
index b49e94a7f1..843024cfb0 100644
--- a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
+++ b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
SRCREV = "12"
PV = "0.0+r${SRCPV}"
-PR = "r5"
+PR = "r6"
#RRECOMMENDS_${PN} = "acct"
@@ -27,13 +27,13 @@ do_compile() {
}
do_install() {
- install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
- install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
- install -m 0755 ${S}/ubootchartd ${D}/sbin
- install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
- install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
- install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+ install -m 0755 -d ${D}${base_sbindir} ${D}${sysconfdir}/ubootchart ${D}${datadir}/applications
+ install -m 0755 ${S}/ubootchartd_bin ${D}${base_sbindir}
+ install -m 0755 ${S}/ubootchartd ${D}${base_sbindir}
+ install -m 0644 ${S}/ubootchart.conf ${D}${sysconfdir}/ubootchart
+ install -m 0755 ${S}/start.sh ${D}${sysconfdir}/ubootchart
+ install -m 0755 ${S}/finish.sh ${D}${sysconfdir}/ubootchart
- install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
- install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
+ install -m 0755 ${WORKDIR}/ubootchart-stop ${D}${base_sbindir}
+ install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}${datadir}/applications
}