aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-03 17:14:47 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-09 07:56:11 -0700
commit8536c410c54956027807e80f37586fb1f4d29af9 (patch)
tree01b5b58356d9c65da5f96739ea6f463613915f99
parentc10d89b201c3854eaa1f1387a8ad684f57b84174 (diff)
downloadopenembedded-core-8536c410c54956027807e80f37586fb1f4d29af9.tar.gz
xserver-nodm-init: remove xuser creation, RDEPEND on xuser-account
[YOCTO #4345] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init.bb13
1 files changed, 2 insertions, 11 deletions
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
index d2797a99d1..8490c81b48 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
PR = "r31"
-RDEPENDS_${PN} = "sudo"
+RDEPENDS_${PN} = "sudo xuser-account"
SRC_URI = "file://xserver-nodm \
file://Xusername \
@@ -23,17 +23,8 @@ do_install() {
fi
}
-inherit update-rc.d useradd
+inherit update-rc.d
INITSCRIPT_NAME = "xserver-nodm"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
-# Use fixed Xusername of xuser for now, this will need to be
-# fixed if the Xusername changes from xuser
-# IMPORTANT: because xuser is shared with connman, please make sure the
-# USERADD_PARAM is in sync with the one in connman.inc
-USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--create-home \
- --groups video,tty,audio,input \
- --user-group xuser"
-