aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-07-31 21:59:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-02 15:25:12 +0100
commitd8ca8b21c6959e772fa1b437ce498b7759fae0ab (patch)
tree628710699dd787491d4cf3488845922cc89901ca
parentf6362c5248914485fc8bf3c3f0ca6cc962bf753e (diff)
downloadopenembedded-core-d8ca8b21c6959e772fa1b437ce498b7759fae0ab.tar.gz
python-setuptools: Fix setuptools install libdir != /usr/lib
--install-lib= is required to be passed via distutils install otherwise the install location gets set to whatever the python-native location is. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-setuptools_0.6c11.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
index a769714ba2..24dd9e5cfe 100644
--- a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
+++ b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
@@ -5,7 +5,7 @@ LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
SRCNAME = "setuptools"
-PR = "ml4"
+PR = "ml5"
DEPENDS += "python"
DEPENDS_virtclass-native += "python-native"
@@ -16,6 +16,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
do_install_prepend() {
install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
}