summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:15:59 -0800
commit91e54d9967d8237abf0cc9aab408bad9bbb4c0b7 (patch)
tree25db9e6f636cb9620c0d526011126cbbec0f05b6
parent684a2533a2b25b900e12f7da912a2c729d60b69d (diff)
downloadopenembedded-core-91e54d9967d8237abf0cc9aab408bad9bbb4c0b7.tar.gz
libical: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch17
1 files changed, 7 insertions, 10 deletions
diff --git a/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch b/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
index c5c0cb076e..b50f50e701 100644
--- a/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
+++ b/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
@@ -14,11 +14,11 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
CMakeLists.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d5aad80..5cc9863 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -91,8 +91,7 @@ if(SHARED_ONLY)
+Index: libical-2.0.0/CMakeLists.txt
+===================================================================
+--- libical-2.0.0.orig/CMakeLists.txt
++++ libical-2.0.0/CMakeLists.txt
+@@ -116,8 +116,7 @@ if(SHARED_ONLY)
set(LIBRARY_TYPE SHARED)
endif()
@@ -26,8 +26,5 @@ index d5aad80..5cc9863 100644
-find_package(Perl REQUIRED)
+set(PERL_EXECUTABLE perl)
- # MSVC specific definitions
- if(WIN32)
---
-2.1.4
-
+ # Ensure finding 64bit libs when using 64-bit compilers
+ if(CMAKE_CL_64)