summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild <allenwild93@gmail.com>2018-05-06 19:00:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:00:27 +0100
commite48cd8423562d4b03bdf55ba04873b7582f12452 (patch)
tree5c40a5b81d57e75ec5b7298df74ace3feeb6c973
parent81dc858a24cc5b5dc547356eb22f00dde9801b6f (diff)
downloadopenembedded-core-e48cd8423562d4b03bdf55ba04873b7582f12452.tar.gz
xz: use update-alternatives
Installing xz and busybox together may cause conflicts for xz, xzcat, unxz, and their lzma variants. In the default configuration, xzcat is silently replaced with a symlink to busybox. If busybox is compiled with CONFIG_XZ=y, its postinst fails during do_rootfs. Using update-alternatives to xz handles these conflicts properly. Signed-off-by: Allen Wild <allenwild93@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/xz/xz_5.2.3.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/xz/xz_5.2.3.bb b/meta/recipes-extended/xz/xz_5.2.3.bb
index c0f8b82f64..65168920d1 100644
--- a/meta/recipes-extended/xz/xz_5.2.3.bb
+++ b/meta/recipes-extended/xz/xz_5.2.3.bb
@@ -31,6 +31,11 @@ PACKAGES =+ "liblzma"
FILES_liblzma = "${libdir}/liblzma*${SOLIBS}"
+inherit update-alternatives
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "xz xzcat unxz \
+ lzma lzcat unlzma"
+
BBCLASSEXTEND = "native nativesdk"
export CONFIG_SHELL="/bin/sh"