summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-19 14:51:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-19 20:43:21 +0100
commitad83f35c012e84dc8d2d27e02a4847568b4f3f35 (patch)
treea6b79b4070ecc71637655d16eb3a62167782aff7
parent641529503a4bce628327855dc4769b0e57a9cb1d (diff)
downloadopenembedded-core-ad83f35c012e84dc8d2d27e02a4847568b4f3f35.tar.gz
openembedded-core-ad83f35c012e84dc8d2d27e02a4847568b4f3f35.tar.bz2
openembedded-core-ad83f35c012e84dc8d2d27e02a4847568b4f3f35.zip
libxcrypt-compat: Add recipe to build the obsolete APIs
Add a recipe which is able to build the obsolete APIs. This is mainly to support uninative which needs to have both the new and obsolete APIs available to support the different host combinations. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/distro/include/maintainers.inc1
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt-compat_4.4.6.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index f41d7e17ba..f034e3adc8 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -410,6 +410,7 @@ RECIPE_MAINTAINER_pn-libxcb = "Armin Kuster <akuster808@gmail.com>"
RECIPE_MAINTAINER_pn-libxcomposite = "Armin Kuster <akuster808@gmail.com>"
RECIPE_MAINTAINER_pn-libxcursor = "Armin Kuster <akuster808@gmail.com>"
RECIPE_MAINTAINER_pn-libxcrypt = "Khem Raj <raj.khem@gmail.com>"
+RECIPE_MAINTAINER_pn-libxcrypt-compat = "Khem Raj <raj.khem@gmail.com>"
RECIPE_MAINTAINER_pn-libxdamage = "Armin Kuster <akuster808@gmail.com>"
RECIPE_MAINTAINER_pn-libxdmcp = "Armin Kuster <akuster808@gmail.com>"
RECIPE_MAINTAINER_pn-libxext = "Armin Kuster <akuster808@gmail.com>"
diff --git a/meta/recipes-core/libxcrypt/libxcrypt-compat_4.4.6.bb b/meta/recipes-core/libxcrypt/libxcrypt-compat_4.4.6.bb
new file mode 100644
index 0000000000..ebc4648a18
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt-compat_4.4.6.bb
@@ -0,0 +1,18 @@
+#
+# This provides libcrypto.so.1 which contains obsolete APIs, needed for uninative in particular
+#
+
+require libxcrypt_${PV}.bb
+
+PROVIDES = ""
+AUTO_LIBNAME_PKGS = ""
+EXCLUDE_FROM_WORLD = "1"
+
+API = "--enable-obsolete-api"
+
+do_install_append () {
+ rm -rf ${D}${includedir}
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${datadir}
+}
+