summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2019-11-26 23:08:28 +0500
committerAnuj Mittal <anuj.mittal@intel.com>2019-12-06 13:14:48 +0800
commita6bd358a27a9346ab364734ca22f35b30f4eb590 (patch)
tree3ce423f525733d29224db3690a315f3fc71b8d24
parentf3e7298c32c430dfc955a2023474810ae32926ba (diff)
downloadopenembedded-core-a6bd358a27a9346ab364734ca22f35b30f4eb590.tar.gz
dosfstools: fix CP437 error from `dosfsck -l`
Fix this error seen when using dosfsck -l to list fs contents: CP437: Invalid argument (From OE-Core rev: 8a5fdac3c2d207b2cfac64ec2a2626c3ef154d84) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools_4.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
index 69aa81af44..23b8836670 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
+++ b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
@@ -23,3 +23,6 @@ EXTRA_OECONF = "--without-udev --enable-compat-symlinks"
CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
BBCLASSEXTEND = "native"
+
+# Add codepage437 to avoid error from `dosfsck -l`
+RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"