summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-05-25 23:28:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-28 10:29:20 +0100
commit0622b7e17b5c3db80a21c11e3079392552f144ea (patch)
tree682a44b55aa768d269237ef6aa54d8fe62ebb7fe
parent464a1c16db1d7cc950eaee43bd8a47124dc4398f (diff)
downloadopenembedded-core-0622b7e17b5c3db80a21c11e3079392552f144ea.tar.gz
ethtool: update to 5.1
Changelog: * Feature: Add support for 200Gbps (50Gbps per lane) link mode * Feature: simplify handling of PHY tunable downshift * Feature: add support for PHY tunable Fast Link Down * Feature: add PHY Fast Link Down tunable to man page * Feature: Add a 'start N' option when specifying the Rx flow hash indirection table. * Feature: Add bash-completion script * Feature: add 10000baseR_FEC link mode name * Fix: qsfp: fix special value comparison * Feature: move option parsing related code into function * Feature: move cmdline_coalesce out of do_scoalesce * Feature: introduce new ioctl for per-queue settings * Feature: support per-queue sub command --show-coalesce * Feature: support per-queue sub command --coalesce * Fix: fix up dump_coalesce output to match actual option names * Feature: fec: add pretty dump Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch10
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.1.bb (renamed from meta/recipes-extended/ethtool/ethtool_5.0.bb)7
2 files changed, 10 insertions, 7 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
index b145188d7f..7a0e38a394 100644
--- a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
+++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
@@ -1,4 +1,4 @@
-From 1484545a150de79483b6e2a74be02ebd030f1920 Mon Sep 17 00:00:00 2001
+From 2ca4c2492c4a06b28012e3e1033d10aa48f153b4 Mon Sep 17 00:00:00 2001
From: Tudor Florea <tudor.florea@enea.com>
Date: Wed, 28 May 2014 18:59:54 +0200
Subject: [PATCH] ethtool: use serial-tests config needed by ptest.
@@ -9,17 +9,16 @@ serial-tests is required to generate those targets.
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Upstream-Status: Inappropriate
(default automake behavior incompatible with ptest)
-
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index e891d91..600f8a8 100644
+index 2941a65..b0a1896 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
- AC_INIT(ethtool, 5.0, netdev@vger.kernel.org)
+ AC_INIT(ethtool, 5.1, netdev@vger.kernel.org)
AC_PREREQ(2.52)
AC_CONFIG_SRCDIR([ethtool.c])
-AM_INIT_AUTOMAKE([gnu])
@@ -27,3 +26,6 @@ index e891d91..600f8a8 100644
AC_CONFIG_HEADERS([ethtool-config.h])
AM_MAINTAINER_MODE
+--
+2.17.1
+
diff --git a/meta/recipes-extended/ethtool/ethtool_5.0.bb b/meta/recipes-extended/ethtool/ethtool_5.1.bb
index 76cdf9c4e7..d379d93bcf 100644
--- a/meta/recipes-extended/ethtool/ethtool_5.0.bb
+++ b/meta/recipes-extended/ethtool/ethtool_5.1.bb
@@ -11,10 +11,11 @@ SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
file://avoid_parallel_tests.patch \
"
-SRC_URI[md5sum] = "8998c9eb7e491b0aec420a807ce52ba6"
-SRC_URI[sha256sum] = "cc53a6d4d5643f8993ef20d6b638f88d9035529a9e777e222073c3a5b9237178"
+SRC_URI[md5sum] = "5d3aad86aec055348a37e867695a744a"
+SRC_URI[sha256sum] = "4edb1fa4d7cf5667a5958d4213f61609f96d02cda90d2b6ec440561f8f8ffbf2"
+
+inherit autotools ptest bash-completion
-inherit autotools ptest
RDEPENDS_${PN}-ptest += "make"
do_compile_ptest() {