summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2014-01-08 12:13:26 +0200
committerSaul Wold <sgw@linux.intel.com>2014-01-08 22:54:55 -0800
commit0f81a4b17ab9ea1b3cc69629aec3f3d2176f8153 (patch)
treea737c77be7c1c0f7eebb0c65ed221c2254dc6b65
parent25d1b821809a5e05fd83fa7b9d411014e16bdd95 (diff)
downloadopenembedded-core-0f81a4b17ab9ea1b3cc69629aec3f3d2176f8153.tar.gz
qemu: upgrade to 1.7.0
linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch file no longer needed, included in upstream. qemu-native tested on all architectures, host machine is Ubuntu Linux 13.10 x86-64. Basic X11 and networking tests performed. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/qemu/files/linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch92
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc1
-rw-r--r--meta/recipes-devtools/qemu/qemu/disable-grabs.patch (renamed from meta/recipes-devtools/qemu/files/disable-grabs.patch)0
-rw-r--r--meta/recipes-devtools/qemu/qemu/fix-libcap-header-issue-on-some-distro.patch (renamed from meta/recipes-devtools/qemu/files/fix-libcap-header-issue-on-some-distro.patch)0
-rw-r--r--meta/recipes-devtools/qemu/qemu/fxrstorssefix.patch (renamed from meta/recipes-devtools/qemu/files/fxrstorssefix.patch)0
-rw-r--r--meta/recipes-devtools/qemu/qemu/larger_default_ram_size.patch (renamed from meta/recipes-devtools/qemu/files/larger_default_ram_size.patch)0
-rw-r--r--meta/recipes-devtools/qemu/qemu/no-strip.patch (renamed from meta/recipes-devtools/qemu/files/no-strip.patch)0
-rw-r--r--meta/recipes-devtools/qemu/qemu/powerpc_rom.bin (renamed from meta/recipes-devtools/qemu/files/powerpc_rom.bin)bin4096 -> 4096 bytes
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.7.0.bb (renamed from meta/recipes-devtools/qemu/qemu_1.6.1.bb)4
9 files changed, 2 insertions, 95 deletions
diff --git a/meta/recipes-devtools/qemu/files/linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch b/meta/recipes-devtools/qemu/files/linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch
deleted file mode 100644
index eb638960dd..0000000000
--- a/meta/recipes-devtools/qemu/files/linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Upstream-Status: Backport
-
-From 53d09b761f032f50c4424e8649396a9041070bae Mon Sep 17 00:00:00 2001
-From: "Edgar E. Iglesias" <edgar.iglesias@gmail.com>
-Date: Mon, 23 Sep 2013 14:11:53 +0200
-Subject: [PATCH] linux-user: Handle SOCK_CLOEXEC/NONBLOCK if unavailable on
- host
-
-If the host lacks SOCK_CLOEXEC, bail out with -EINVAL.
-If the host lacks SOCK_ONONBLOCK, try to emulate it with fcntl()
-and O_NONBLOCK.
-
-Signed-off-by: Edgar E. Iglesias <edgar.iglesias@gmail.com>
-Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
----
- linux-user/syscall.c | 40 +++++++++++++++++++++++++++++++++++++---
- 1 file changed, 37 insertions(+), 3 deletions(-)
-
-diff --git a/linux-user/syscall.c b/linux-user/syscall.c
-index b3822b3..4a14a43 100644
---- a/linux-user/syscall.c
-+++ b/linux-user/syscall.c
-@@ -1773,7 +1773,7 @@ static void unlock_iovec(struct iovec *vec, abi_ulong target_addr,
- free(vec);
- }
-
--static inline void target_to_host_sock_type(int *type)
-+static inline int target_to_host_sock_type(int *type)
- {
- int host_type = 0;
- int target_type = *type;
-@@ -1790,22 +1790,56 @@ static inline void target_to_host_sock_type(int *type)
- break;
- }
- if (target_type & TARGET_SOCK_CLOEXEC) {
-+#if defined(SOCK_CLOEXEC)
- host_type |= SOCK_CLOEXEC;
-+#else
-+ return -TARGET_EINVAL;
-+#endif
- }
- if (target_type & TARGET_SOCK_NONBLOCK) {
-+#if defined(SOCK_NONBLOCK)
- host_type |= SOCK_NONBLOCK;
-+#elif !defined(O_NONBLOCK)
-+ return -TARGET_EINVAL;
-+#endif
- }
- *type = host_type;
-+ return 0;
-+}
-+
-+/* Try to emulate socket type flags after socket creation. */
-+static int sock_flags_fixup(int fd, int target_type)
-+{
-+#if !defined(SOCK_NONBLOCK) && defined(O_NONBLOCK)
-+ if (target_type & TARGET_SOCK_NONBLOCK) {
-+ int flags = fcntl(fd, F_GETFL);
-+ if (fcntl(fd, F_SETFL, O_NONBLOCK | flags) == -1) {
-+ close(fd);
-+ return -TARGET_EINVAL;
-+ }
-+ }
-+#endif
-+ return fd;
- }
-
- /* do_socket() Must return target values and target errnos. */
- static abi_long do_socket(int domain, int type, int protocol)
- {
-- target_to_host_sock_type(&type);
-+ int target_type = type;
-+ int ret;
-+
-+ ret = target_to_host_sock_type(&type);
-+ if (ret) {
-+ return ret;
-+ }
-
- if (domain == PF_NETLINK)
- return -EAFNOSUPPORT; /* do not NETLINK socket connections possible */
-- return get_errno(socket(domain, type, protocol));
-+ ret = get_errno(socket(domain, type, protocol));
-+ if (ret >= 0) {
-+ ret = sock_flags_fixup(ret, target_type);
-+ }
-+ return ret;
- }
-
- /* do_bind() Must return target values and target errnos. */
---
-1.8.2.1
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index fa9306dfb0..8705dc78a4 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -19,7 +19,6 @@ SRC_URI = "\
file://no-strip.patch \
file://larger_default_ram_size.patch \
file://disable-grabs.patch \
- file://linux-user-Handle-SOCK_CLOEXEC-NONBLOCK-if-unavailab.patch \
"
SRC_URI_append_class-native = "\
diff --git a/meta/recipes-devtools/qemu/files/disable-grabs.patch b/meta/recipes-devtools/qemu/qemu/disable-grabs.patch
index 41726b1c87..41726b1c87 100644
--- a/meta/recipes-devtools/qemu/files/disable-grabs.patch
+++ b/meta/recipes-devtools/qemu/qemu/disable-grabs.patch
diff --git a/meta/recipes-devtools/qemu/files/fix-libcap-header-issue-on-some-distro.patch b/meta/recipes-devtools/qemu/qemu/fix-libcap-header-issue-on-some-distro.patch
index 13a6ea23b1..13a6ea23b1 100644
--- a/meta/recipes-devtools/qemu/files/fix-libcap-header-issue-on-some-distro.patch
+++ b/meta/recipes-devtools/qemu/qemu/fix-libcap-header-issue-on-some-distro.patch
diff --git a/meta/recipes-devtools/qemu/files/fxrstorssefix.patch b/meta/recipes-devtools/qemu/qemu/fxrstorssefix.patch
index 59ab0f50fa..59ab0f50fa 100644
--- a/meta/recipes-devtools/qemu/files/fxrstorssefix.patch
+++ b/meta/recipes-devtools/qemu/qemu/fxrstorssefix.patch
diff --git a/meta/recipes-devtools/qemu/files/larger_default_ram_size.patch b/meta/recipes-devtools/qemu/qemu/larger_default_ram_size.patch
index 711c36071d..711c36071d 100644
--- a/meta/recipes-devtools/qemu/files/larger_default_ram_size.patch
+++ b/meta/recipes-devtools/qemu/qemu/larger_default_ram_size.patch
diff --git a/meta/recipes-devtools/qemu/files/no-strip.patch b/meta/recipes-devtools/qemu/qemu/no-strip.patch
index d6a4377cd0..d6a4377cd0 100644
--- a/meta/recipes-devtools/qemu/files/no-strip.patch
+++ b/meta/recipes-devtools/qemu/qemu/no-strip.patch
diff --git a/meta/recipes-devtools/qemu/files/powerpc_rom.bin b/meta/recipes-devtools/qemu/qemu/powerpc_rom.bin
index c4044296c5..c4044296c5 100644
--- a/meta/recipes-devtools/qemu/files/powerpc_rom.bin
+++ b/meta/recipes-devtools/qemu/qemu/powerpc_rom.bin
Binary files differ
diff --git a/meta/recipes-devtools/qemu/qemu_1.6.1.bb b/meta/recipes-devtools/qemu/qemu_1.7.0.bb
index 03e28a0fcb..d5265bcf57 100644
--- a/meta/recipes-devtools/qemu/qemu_1.6.1.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.7.0.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
SRC_URI += "file://fxrstorssefix.patch"
SRC_URI_prepend = "http://wiki.qemu.org/download/qemu-${PV}.tar.bz2"
-SRC_URI[md5sum] = "3a897d722457c5a895cd6ac79a28fda0"
-SRC_URI[sha256sum] = "fc736f44aa10478223c881310a7e40fc8386547e9cadf7d01ca4685951605294"
+SRC_URI[md5sum] = "32893941d40d052a5e649efcf06aca06"
+SRC_URI[sha256sum] = "31f333a85f2d14c605a77679904a9668eaeb1b6dc7da53a1665230f46bc21314"
COMPATIBLE_HOST_class-target_mips64 = "null"