summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-11-22 21:38:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-22 22:39:35 +0000
commit163966765d57fe38e13d0b6659795a13bc702e2d (patch)
tree1839e4e10e3edb08a1172144d7c8e85d593e8f4f
parentff156411380640f99ddb058ed8da0626d3183954 (diff)
downloadopenembedded-core-163966765d57fe38e13d0b6659795a13bc702e2d.tar.gz
python3: make tkinter available when enabled
After Python upgrade to 3.11, it requires pkg-config to detect tcl and tk when configure tkinter, so add tcl depends to fix below error. | The necessary bits to build these optional modules were not found: | _tkinter Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3/python3-manifest.json1
-rw-r--r--meta/recipes-devtools/python/python3_3.11.0.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/python3-manifest.json b/meta/recipes-devtools/python/python3/python3-manifest.json
index 64203cf0fc..58e6f28a69 100644
--- a/meta/recipes-devtools/python/python3/python3-manifest.json
+++ b/meta/recipes-devtools/python/python3/python3-manifest.json
@@ -1173,6 +1173,7 @@
"core"
],
"files": [
+ "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/_tkinter.*.so",
"${libdir}/python${PYTHON_MAJMIN}/tkinter"
],
"cached": []
diff --git a/meta/recipes-devtools/python/python3_3.11.0.bb b/meta/recipes-devtools/python/python3_3.11.0.bb
index 93628c76ff..16a9e04cc9 100644
--- a/meta/recipes-devtools/python/python3_3.11.0.bb
+++ b/meta/recipes-devtools/python/python3_3.11.0.bb
@@ -107,6 +107,7 @@ PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
# Use profile guided optimisation by running PyBench inside qemu-user
PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
PACKAGECONFIG[tk] = ",,tk"
+PACKAGECONFIG[tcl] = ",,tcl"
PACKAGECONFIG[gdbm] = ",,gdbm"
PACKAGECONFIG[lto] = "--with-lto,,"