aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-01-14 17:16:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 18:14:53 +0000
commit3cd34c673d2f64e310b474036754e1ead5775d66 (patch)
tree21d86db32239cf30ed56fd9026568cc9012bd310
parenta5e931e0b1d941cc938fe2f49625c54b07fab0ce (diff)
downloadopenembedded-core-3cd34c673d2f64e310b474036754e1ead5775d66.zip
openembedded-core-3cd34c673d2f64e310b474036754e1ead5775d66.tar.gz
openembedded-core-3cd34c673d2f64e310b474036754e1ead5775d66.tar.bz2
dbus: upgrade to 1.10.6
Now that systemd doesn't use DBus directly, dbus can --enable-systemd. In fact this appears to be essential for DBus to work on under modern systemd. python-config.patch refreshed. Package dbus-test-tool into PN-dev, and remove obsolete dbus-glib-tool reference. Remove obsolete --without-dbus-glib option, and dependency on dbus-glib in dbus-test. [ patch originally by Chen, tweaked and message rewritten by RB ] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.10.6.bb (renamed from meta/recipes-core/dbus/dbus-test_1.8.20.bb)6
-rw-r--r--meta/recipes-core/dbus/dbus/python-config.patch21
-rw-r--r--meta/recipes-core/dbus/dbus_1.10.6.bb (renamed from meta/recipes-core/dbus/dbus_1.8.20.bb)18
3 files changed, 28 insertions, 17 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.8.20.bb b/meta/recipes-core/dbus/dbus-test_1.10.6.bb
index f5400a0..a768a09 100644
--- a/meta/recipes-core/dbus/dbus-test_1.8.20.bb
+++ b/meta/recipes-core/dbus/dbus-test_1.10.6.bb
@@ -5,7 +5,7 @@ LICENSE = "AFL-2 | GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
-DEPENDS = "python-pygobject dbus dbus-glib"
+DEPENDS = "python-pygobject dbus"
RDEPENDS_${PN} += "make"
RDEPENDS_${PN}-dev = ""
@@ -18,8 +18,8 @@ SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
"
-SRC_URI[md5sum] = "b49890bbabedab3a1c3f4f73c7ff8b2b"
-SRC_URI[sha256sum] = "5c4fbf4c64621c96e871da91d2b729a5b00536e116d3c4612a469d924b1b703a"
+SRC_URI[md5sum] = "26d0cf3a1c9782cb0e342101f0450440"
+SRC_URI[sha256sum] = "b5fefa08a77edd76cd64d872db949eebc02cf6f3f8be82e4bbc641742af5d35f"
S="${WORKDIR}/dbus-${PV}"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
diff --git a/meta/recipes-core/dbus/dbus/python-config.patch b/meta/recipes-core/dbus/dbus/python-config.patch
index 2944002..da2f10c 100644
--- a/meta/recipes-core/dbus/dbus/python-config.patch
+++ b/meta/recipes-core/dbus/dbus/python-config.patch
@@ -7,19 +7,28 @@ Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
---- dbus-1.6.8/configure.ac.orig 2013-07-11 14:15:58.834554799 -0500
-+++ dbus-1.6.8/configure.ac 2013-07-11 14:14:40.969554848 -0500
-@@ -257,13 +257,6 @@
+---
+ configure.ac | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 80d27b4..becc1cc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -279,13 +279,6 @@ if test "x$enable_tests" = xyes; then
# full test coverage is required, Python is a hard dependency
- AC_MSG_NOTICE([Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygobject])
+ AC_MSG_NOTICE([Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygi])
AM_PATH_PYTHON([2.6])
- AC_MSG_CHECKING([for Python modules for full test coverage])
-- if "$PYTHON" -c "import dbus, gobject, dbus.mainloop.glib"; then
+- if "$PYTHON" -c "import dbus, gi.repository.GObject, dbus.mainloop.glib"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
-- AC_MSG_ERROR([cannot import dbus, gobject, dbus.mainloop.glib Python modules])
+- AC_MSG_ERROR([cannot import dbus, gi.repository.GObject, dbus.mainloop.glib Python modules])
- fi
else
# --enable-tests not given: do not abort if Python is missing
AM_PATH_PYTHON([2.6], [], [:])
+--
+1.9.1
+
diff --git a/meta/recipes-core/dbus/dbus_1.8.20.bb b/meta/recipes-core/dbus/dbus_1.10.6.bb
index 0c7f6b1..5ba3f21 100644
--- a/meta/recipes-core/dbus/dbus_1.8.20.bb
+++ b/meta/recipes-core/dbus/dbus_1.10.6.bb
@@ -20,8 +20,8 @@ SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://0001-configure.ac-support-large-file-for-stat64.patch \
"
-SRC_URI[md5sum] = "b49890bbabedab3a1c3f4f73c7ff8b2b"
-SRC_URI[sha256sum] = "5c4fbf4c64621c96e871da91d2b729a5b00536e116d3c4612a469d924b1b703a"
+SRC_URI[md5sum] = "26d0cf3a1c9782cb0e342101f0450440"
+SRC_URI[sha256sum] = "b5fefa08a77edd76cd64d872db949eebc02cf6f3f8be82e4bbc641742af5d35f"
inherit useradd autotools pkgconfig gettext update-rc.d upstream-version-is-even
@@ -59,15 +59,20 @@ FILES_${PN} = "${bindir}/dbus-daemon* \
${bindir}/dbus-monitor \
${bindir}/dbus-launch \
${bindir}/dbus-run-session \
+ ${bindir}/dbus-update-activation-environment \
${libexecdir}/dbus* \
${sysconfdir} \
${localstatedir} \
${datadir}/dbus-1/services \
${datadir}/dbus-1/system-services \
+ ${datadir}/dbus-1/session.d \
+ ${datadir}/dbus-1/session.conf \
+ ${datadir}/dbus-1/system.d \
+ ${datadir}/dbus-1/system.conf \
${systemd_unitdir}/system/"
FILES_${PN}-lib = "${libdir}/lib*.so.*"
RRECOMMENDS_${PN}-lib = "${PN}"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-test-tool"
pkg_postinst_dbus() {
# If both systemd and sysvinit are enabled, mask the dbus-1 init script
@@ -87,8 +92,7 @@ EXTRA_OECONF = "--disable-tests \
--disable-xml-docs \
--disable-doxygen-docs \
--disable-libaudit \
- --disable-systemd \
- --without-dbus-glib"
+ "
EXTRA_OECONF_append_class-native = " --disable-selinux"
@@ -98,9 +102,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd',
PACKAGECONFIG_class-native = ""
PACKAGECONFIG_class-nativesdk = ""
-# Would like to --enable-systemd but that's a circular build-dependency between
-# systemd<->dbus
-PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir"
+PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/,--disable-systemd --without-systemdsystemunitdir,systemd"
PACKAGECONFIG[x11] = "--with-x --enable-x11-autolaunch,--without-x --disable-x11-autolaunch, virtual/libx11 libsm"
PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"