summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-01 12:56:24 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:50 +0100
commit3f7f13da8ce45b73be7954b47c5e7f427264da59 (patch)
treeddeafced870119f6e28360eeddfc77adf921d90e
parentc4ecd356d17e243655dd580b0636be1fe6ad4e77 (diff)
downloadopenembedded-core-3f7f13da8ce45b73be7954b47c5e7f427264da59.tar.gz
which (GPLv3): inherit update-alternatives to handle install priority
inherit the update-alternatives class to handle install priority issue, which is recommended by poky. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-rw-r--r--meta/recipes-extended/which/which_2.20.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta/recipes-extended/which/which_2.20.bb b/meta/recipes-extended/which/which_2.20.bb
index b7730de3b3..6efb24fcd8 100644
--- a/meta/recipes-extended/which/which_2.20.bb
+++ b/meta/recipes-extended/which/which_2.20.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
DEPENDS = "cwautomacros-native"
-inherit autotools
+inherit autotools update-alternatives
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
file://remove-declaration.patch"
@@ -22,14 +22,6 @@ do_install() {
mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
}
-pkg_postinst_${PN} () {
- if [ "${PN}" = "${BPN}" ] ; then
- update-alternatives --install ${bindir}/which which which.${PN} 100
- fi
-}
-
-pkg_prerm_${PN} () {
- if [ "${PN}" = "${BPN}" ] ; then
- update-alternatives --remove which which.${PN}
- fi
-}
+ALTERNATIVE_NAME = "which"
+ALTERNATIVE_PATH = "which.${PN}"
+ALTERNATIVE_PRIORITY = "100"