summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2016-08-19 11:18:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-20 16:05:28 +0100
commit4c4f440d3a8eb6171f619bceacf57835d1b9841a (patch)
tree3cac50b59365167170d6d085be46a10520898c9f
parent14be679c7b8241b2d0872242ed358e5eb4f7acac (diff)
downloadopenembedded-core-4c4f440d3a8eb6171f619bceacf57835d1b9841a.tar.gz
bootchart2: Add ALTERNATIVE configuration for bootchartd
Since busybox also provides the bootchartd command use the update-alternatives mechanism to address this. Also let bootchartd-stop-initscript RDEPENDS on bootchart2, since /sbin/bootchartd is being called in that script. Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
index d039b1b947..bc8c1a8a88 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
@@ -97,9 +97,11 @@ SRC_URI = "git://github.com/mmeeks/bootchart.git \
S = "${WORKDIR}/git"
SRCREV = "48e0071048564c6af75ab969e842d6dec808da09"
-inherit systemd
-inherit update-rc.d
-inherit python3native
+inherit systemd update-rc.d python3native update-alternatives
+
+ALTERNATIVE_${PN} = "bootchartd"
+ALTERNATIVE_LINK_NAME[bootchartd] = "${base_sbindir}/bootchartd"
+ALTERNATIVE_PRIORITY = "100"
# The only reason to build bootchart2-native is for a native pybootchartgui.
BBCLASSEXTEND = "native"
@@ -142,6 +144,7 @@ DEPENDS_append_class-native = " python3-pycairo-native"
PACKAGES =+ "bootchartd-stop-initscript"
FILES_bootchartd-stop-initscript += "${sysconfdir}/init.d ${sysconfdir}/rc*.d"
+RDEPENDS_bootchartd-stop-initscript = "${PN}"
FILES_${PN} += "${base_libdir}/bootchart/bootchart-collector"
FILES_${PN} += "${base_libdir}/bootchart/tmpfs"