summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-11 15:00:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-13 00:03:51 +0000
commit564c56207edd9a7dcef3ea966580e11a1548115c (patch)
tree52438bed8162db0372aedc7bec804c00e1a786a7
parent541315d6c56df6448f64c262f99d43d5c1e9400b (diff)
downloadopenembedded-core-564c56207edd9a7dcef3ea966580e11a1548115c.tar.gz
gdb: upgrade to 7.10.1
The PPC inferior patch was dropped since an equivalent fix was merged upstream. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/distro/include/tcmode-default.inc2
-rw-r--r--meta/recipes-devtools/gdb/gdb-7.10.1.inc (renamed from meta/recipes-devtools/gdb/gdb-7.9.1.inc)4
-rw-r--r--meta/recipes-devtools/gdb/gdb-cross-canadian_7.10.1.bb (renamed from meta/recipes-devtools/gdb/gdb-cross-canadian_7.9.1.bb)0
-rw-r--r--meta/recipes-devtools/gdb/gdb-cross_7.10.1.bb (renamed from meta/recipes-devtools/gdb/gdb-cross_7.9.1.bb)0
-rw-r--r--meta/recipes-devtools/gdb/gdb.inc1
-rw-r--r--meta/recipes-devtools/gdb/gdb/fix-detection-of-64-bit-PPC-inferior-in-gdbserver.patch56
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.10.1.bb (renamed from meta/recipes-devtools/gdb/gdb_7.9.1.bb)0
7 files changed, 3 insertions, 60 deletions
diff --git a/meta/conf/distro/include/tcmode-default.inc b/meta/conf/distro/include/tcmode-default.inc
index 16507c4464..cd9bfaf295 100644
--- a/meta/conf/distro/include/tcmode-default.inc
+++ b/meta/conf/distro/include/tcmode-default.inc
@@ -25,7 +25,7 @@ PREFERRED_PROVIDER_virtual/gettext ??= "gettext"
GCCVERSION ?= "5.%"
SDKGCCVERSION ?= "${GCCVERSION}"
BINUVERSION ?= "2.25%"
-GDBVERSION ?= "7.9%"
+GDBVERSION ?= "7.10%"
GLIBCVERSION ?= "2.22"
UCLIBCVERSION ?= "1.0%"
LINUXLIBCVERSION ?= "4.1"
diff --git a/meta/recipes-devtools/gdb/gdb-7.9.1.inc b/meta/recipes-devtools/gdb/gdb-7.10.1.inc
index 1ca95afdcc..a9267d5548 100644
--- a/meta/recipes-devtools/gdb/gdb-7.9.1.inc
+++ b/meta/recipes-devtools/gdb/gdb-7.10.1.inc
@@ -4,6 +4,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674"
-SRC_URI[md5sum] = "f3b97de919a9dba84490b2e076ec4cb0"
-SRC_URI[sha256sum] = "4994ad986726ac4128a6f1bd8020cd672e9a92aa76b80736563ef992992764ef"
+SRC_URI[md5sum] = "b93a2721393e5fa226375b42d567d90b"
+SRC_URI[sha256sum] = "ff14f8050e6484508c73cbfa63731e57901478490ca1672dc0b5e2b03f6af622"
diff --git a/meta/recipes-devtools/gdb/gdb-cross-canadian_7.9.1.bb b/meta/recipes-devtools/gdb/gdb-cross-canadian_7.10.1.bb
index 301035940c..301035940c 100644
--- a/meta/recipes-devtools/gdb/gdb-cross-canadian_7.9.1.bb
+++ b/meta/recipes-devtools/gdb/gdb-cross-canadian_7.10.1.bb
diff --git a/meta/recipes-devtools/gdb/gdb-cross_7.9.1.bb b/meta/recipes-devtools/gdb/gdb-cross_7.10.1.bb
index 3a95cfb035..3a95cfb035 100644
--- a/meta/recipes-devtools/gdb/gdb-cross_7.9.1.bb
+++ b/meta/recipes-devtools/gdb/gdb-cross_7.10.1.bb
diff --git a/meta/recipes-devtools/gdb/gdb.inc b/meta/recipes-devtools/gdb/gdb.inc
index 2162cadb9e..e970450fa3 100644
--- a/meta/recipes-devtools/gdb/gdb.inc
+++ b/meta/recipes-devtools/gdb/gdb.inc
@@ -4,7 +4,6 @@ inherit gettext
SRC_URI += "file://0002-Change-order-of-CFLAGS.patch \
file://0003-Add-support-for-Renesas-SH-sh4-architecture.patch \
- file://fix-detection-of-64-bit-PPC-inferior-in-gdbserver.patch \
file://0001-Use-exported-definitions-of-SIGRTMIN.patch \
"
#LDFLAGS_append = " -s"
diff --git a/meta/recipes-devtools/gdb/gdb/fix-detection-of-64-bit-PPC-inferior-in-gdbserver.patch b/meta/recipes-devtools/gdb/gdb/fix-detection-of-64-bit-PPC-inferior-in-gdbserver.patch
deleted file mode 100644
index 2854352309..0000000000
--- a/meta/recipes-devtools/gdb/gdb/fix-detection-of-64-bit-PPC-inferior-in-gdbserver.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 4fe67dbafa1bee679daecc12ed30621d5c2605de Mon Sep 17 00:00:00 2001
-From: Yao Qi <yao@codesourcery.com>
-Date: Mon, 11 May 2015 10:57:33 +0800
-Subject: [PATCH] Fix detection of 64-bit PPC inferior in gdbserver
-
-Issue #16775
-
-* gdbserver/linux-ppc-low.c (ppc_arch_setup): Change variable msr to type
-'unsigned long'. Check bit 63 or bit 31 is one.
-
-https://sourceware.org/ml/gdb-patches/2014-12/msg00239.html
-Written by: Yao Qi <yao@codesourcery.com>
-
-Upstream-Status: Pending
-
-Signed-off-by: Yuanjie Huang <yuanjie.huang@windriver.com>
----
- gdb/gdbserver/linux-ppc-low.c | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/gdb/gdbserver/linux-ppc-low.c b/gdb/gdbserver/linux-ppc-low.c
-index 63d4218..a62cf22 100644
---- a/gdb/gdbserver/linux-ppc-low.c
-+++ b/gdb/gdbserver/linux-ppc-low.c
-@@ -374,7 +374,7 @@ ppc_arch_setup (void)
- {
- const struct target_desc *tdesc;
- #ifdef __powerpc64__
-- long msr;
-+ unsigned long msr;
- struct regcache *regcache;
-
- /* On a 64-bit host, assume 64-bit inferior process with no
-@@ -384,13 +384,16 @@ ppc_arch_setup (void)
- current_process ()->tdesc = tdesc;
- ppc_hwcap = 0;
-
-- /* Only if the high bit of the MSR is set, we actually have
-- a 64-bit inferior. */
-+ /* We actually have a 64-bit inferior only if the certain bit of the
-+ MSR is set. The PowerISA Book III-S MSR is different from the
-+ PowerISA Book III-E MSR. The Book III-S MSR is 64 bits wide, and
-+ its MSR[SF] is the bit 0 of a 64-bit value. Book III-E MSR is 32
-+ bits wide, and its MSR[CM] is the bit 0 of a 32-bit value. */
- regcache = new_register_cache (tdesc);
- fetch_inferior_registers (regcache, find_regno (tdesc, "msr"));
- collect_register_by_name (regcache, "msr", &msr);
- free_register_cache (regcache);
-- if (msr < 0)
-+ if (msr & 0x8000000080000000)
- {
- ppc_get_hwcap (&ppc_hwcap);
- if (ppc_hwcap & PPC_FEATURE_CELL)
---
-1.8.5.2.233.g932f7e4
-
diff --git a/meta/recipes-devtools/gdb/gdb_7.9.1.bb b/meta/recipes-devtools/gdb/gdb_7.10.1.bb
index cd52e27d56..cd52e27d56 100644
--- a/meta/recipes-devtools/gdb/gdb_7.9.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.10.1.bb