summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-14 12:49:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-14 22:31:56 +0100
commit6c195acb400efeeebdacdd8d081b35f7417a694c (patch)
tree342ae47e4dc1ee1314ad7633b42f6380348ac33b
parent7a497d8f30f21bafc78d0f22f3442a9cc99544cb (diff)
downloadopenembedded-core-6c195acb400efeeebdacdd8d081b35f7417a694c.tar.gz
python: Update now reproducibile builds are the default
Now reproducible builds are the default move the qemu-usermode check to anon python code so that invalid configurations are detected. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.10.0.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python3_3.10.0.bb b/meta/recipes-devtools/python/python3_3.10.0.bb
index 2e850710b6..e3300b6495 100644
--- a/meta/recipes-devtools/python/python3_3.10.0.bb
+++ b/meta/recipes-devtools/python/python3_3.10.0.bb
@@ -95,15 +95,8 @@ CACHED_CONFIGUREVARS = " \
ac_cv_working_tzset=yes \
"
-def possibly_include_pgo(d):
- # PGO currently causes builds to not be reproducible, so disable it for
- # now. See YOCTO #13407
- if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
- return 'pgo'
-
- return ''
-
-PACKAGECONFIG:class-target ??= "readline ${@possibly_include_pgo(d)} gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
+# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
+PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
PACKAGECONFIG:class-native ??= "readline gdbm"
PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
PACKAGECONFIG[readline] = ",,readline"
@@ -320,6 +313,9 @@ python(){
d.setVar('PACKAGES', ' '.join(packages))
d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
+
+ if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
+ bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
}
# Files needed to create a new manifest