summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:17:41 +0100
commit6f0eebbd12d79a86dd4a79f87b6be4758439a3f5 (patch)
tree1842455c74c36f6d6b5d84e2bae65aad805583ca
parent11267f8a1ccf65142988b095351a84b0fa0fcbcf (diff)
downloadopenembedded-core-6f0eebbd12d79a86dd4a79f87b6be4758439a3f5.tar.gz
xinetd: use ${sbindir} and ${sysconfdir} instead of /usr/sbin and /etc
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.15.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.15.bb b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
index a1421436c6..2139e7493b 100644
--- a/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
@@ -7,7 +7,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
DEPENDS = ""
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
file://xinetd.init \
@@ -38,15 +38,15 @@ do_install() {
# Same here, the Makefile does some really stupid things,
# but since we only want two files why not override
# do_install from autotools and doing it ourselfs?
- install -d "${D}/usr/sbin"
- install -d "${D}/etc/init.d"
- install -d "${D}/etc/xinetd.d"
- install -d "${D}/etc/default"
- install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
- install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
- install -m 644 "${WORKDIR}/xinetd.default" "${D}/etc/default/xinetd"
- install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
- install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
+ install -d "${D}${sbindir}"
+ install -d "${D}${sysconfdir}/init.d"
+ install -d "${D}${sysconfdir}/xinetd.d"
+ install -d "${D}${sysconfdir}/default"
+ install -m 644 "${WORKDIR}/xinetd.conf" "${D}${sysconfdir}"
+ install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
+ install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
+ install -m 755 "${S}/xinetd/xinetd" "${D}${sbindir}"
+ install -m 755 "${S}/xinetd/itox" "${D}${sbindir}"
}
CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"