summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Zapolskiy <vladimir_zapolskiy@mentor.com>2012-10-11 17:12:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 12:03:28 +0100
commit76138d4b183eff28c678ab13cb1a6da358be2340 (patch)
tree3ecaf0df014aea43ca554f6d9a0293ef6ca72578
parent0479242a18661cb7fc3d76d208c82fe6ae4378ce (diff)
downloadopenembedded-core-76138d4b183eff28c678ab13cb1a6da358be2340.tar.gz
lttng: support more compatible hosts
THis change extends COMAPTIBLE_HOST matchings, which allows to include more hosts with TARGET_OS like linux-gnuspe or linux-gnueabi etc. Signed-off-by: Vladimir Zapolskiy <vladimir_zapolskiy@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-kernel/lttng-2.0/babeltrace_0.12.bb4
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.5.bb4
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.4.bb4
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng2-ust_2.0.5.bb4
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_0.16.bb4
-rw-r--r--meta/recipes-support/liburcu/liburcu_0.6.7.bb5
6 files changed, 12 insertions, 13 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/babeltrace_0.12.bb b/meta/recipes-kernel/lttng-2.0/babeltrace_0.12.bb
index eaf7eeb2bd..95d65f5737 100644
--- a/meta/recipes-kernel/lttng-2.0/babeltrace_0.12.bb
+++ b/meta/recipes-kernel/lttng-2.0/babeltrace_0.12.bb
@@ -12,7 +12,7 @@ DEPENDS = "gtk+ util-linux"
SRCREV = "0d8f8c2ea27df096269aa76b4baeab26b68b95d4"
PV = "0.12+git${SRCPV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.efficios.com/babeltrace.git;protocol=git"
@@ -25,4 +25,4 @@ do_configure_prepend () {
# Due to liburcu not building for MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.5.bb b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.5.bb
index 4c78f36ba0..d81e9b8f5c 100644
--- a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.5.bb
+++ b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.5.bb
@@ -12,7 +12,7 @@ inherit module
SRCREV = "4d3e89e379fc66480d729abe8daa5c86eb585400"
PV = "2.0.pre11+git${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
@@ -27,4 +27,4 @@ S = "${WORKDIR}/git"
# Due to liburcu not building for MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.4.bb b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.4.bb
index cf280c458f..cf5731d9f5 100644
--- a/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.4.bb
+++ b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.4.bb
@@ -13,7 +13,7 @@ DEPENDS = "liburcu popt lttng2-ust"
SRCREV = "8c3919ea2dc77fdd47fb1c90e41490a20bb4d478"
PV = "v2.0.1+git${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.lttng.org/lttng-tools.git;protocol=git"
@@ -34,4 +34,4 @@ INSANE_SKIP_${PN}-dbg = "libexec"
# Due to liburcu not building for MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'
diff --git a/meta/recipes-kernel/lttng-2.0/lttng2-ust_2.0.5.bb b/meta/recipes-kernel/lttng-2.0/lttng2-ust_2.0.5.bb
index 8f650a4ae2..5e9a529a2b 100644
--- a/meta/recipes-kernel/lttng-2.0/lttng2-ust_2.0.5.bb
+++ b/meta/recipes-kernel/lttng-2.0/lttng2-ust_2.0.5.bb
@@ -14,7 +14,7 @@ DEPENDS = "liburcu util-linux"
SRCREV = "a367ee66aad3ffd21ef64d1b24efc6f862e09562"
PV = "2.0.2+git${SRCPV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.lttng.org/lttng-ust.git;protocol=git"
@@ -27,4 +27,4 @@ do_configure_prepend () {
# Due to liburcu not building for MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'
diff --git a/meta/recipes-kernel/lttng/lttng-ust_0.16.bb b/meta/recipes-kernel/lttng/lttng-ust_0.16.bb
index e9540837ca..3618a2dde9 100644
--- a/meta/recipes-kernel/lttng/lttng-ust_0.16.bb
+++ b/meta/recipes-kernel/lttng/lttng-ust_0.16.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e647752e045a8c45b6f583771bd561ef \
DEPENDS = "liburcu"
-PR = "r0"
+PR = "r1"
PE = "1"
SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz"
@@ -28,5 +28,5 @@ inherit autotools
# Due to liburcu not building on MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'
diff --git a/meta/recipes-support/liburcu/liburcu_0.6.7.bb b/meta/recipes-support/liburcu/liburcu_0.6.7.bb
index be73856612..361780c20a 100644
--- a/meta/recipes-support/liburcu/liburcu_0.6.7.bb
+++ b/meta/recipes-support/liburcu/liburcu_0.6.7.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b472dc110d38774921e1d5ccb0065fff \
file://urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
file://urcu/uatomic/x86.h;beginline=4;endline=21;md5=220552f72c55b102f2ee35929734ef42"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
@@ -20,5 +20,4 @@ inherit autotools
# liburcu, which is only used by lttng-ust, may not build on other
# platforms, like MIPS.
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'
-
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'