summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-10-21 16:16:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:31:27 +0000
commit7c33f0b1ee35031aa97e5e5231f53d8502b583c9 (patch)
tree731d3b3f2b2cfc3d09f8cbe5aa8a5d39740ab540
parent6a000d734c2fe57b4a601fe7e7373096345b02b4 (diff)
downloadopenembedded-core-7c33f0b1ee35031aa97e5e5231f53d8502b583c9.tar.gz
perf: create directories before copying single files
If we need to copy a single file from the linux source tree into the perf source tree, we need to ensure that the directory structure it requires has been created first. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 0f5df74f11..66d3c1d325 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -153,6 +153,8 @@ python copy_perf_source_from_kernel() {
if os.path.isdir(src):
oe.path.copyhardlinktree(src, dest)
else:
+ src_path = os.path.dirname(s)
+ os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
bb.utils.copyfile(src, dest)
}