summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-17 01:41:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-18 13:48:12 +0100
commit86430833b463d606ffc345ad6b7e51840dc9f9ba (patch)
treeb9889e0e9742ac3d512391a52dd0bff300a4f9e4
parentc984ef67f8dff27e0ce24628f28d196cdc76055e (diff)
downloadopenembedded-core-86430833b463d606ffc345ad6b7e51840dc9f9ba.tar.gz
python3-tomli: add recipe for 1.2.1
A lil' TOML parser This is a runtime dependency for setuptools-scm upgrade as well as for several other Python Packaging Authority (pypa) tools that will be replacing distutils and setuptools in the future. Upstream does not have a setup.py, but rather relies on flit_core to build. This introduces a circular dependency, as flit_core has a runtime dependency on tomli. Borrow a setup.py from Gentoo until a better solution is found by upstream Python Packaging Authority (pypa). Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/distro/include/maintainers.inc1
-rw-r--r--meta/recipes-devtools/python/python3-tomli_1.2.1.bb20
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 3ffb065804..baec2bef4d 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -637,6 +637,7 @@ RECIPE_MAINTAINER:pn-python3-sortedcontainers = "Tim Orling <timothy.t.orling@in
RECIPE_MAINTAINER:pn-python3-subunit = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
RECIPE_MAINTAINER:pn-python3-testtools = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
RECIPE_MAINTAINER:pn-python3-toml = "Tim Orling <timothy.t.orling@intel.com>"
+RECIPE_MAINTAINER:pn-python3-tomli = "Tim Orling <timothy.t.orling@intel.com>"
RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander Kanavin <alex.kanavin@gmail.com>"
RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <timothy.t.orling@intel.com>"
RECIPE_MAINTAINER:pn-python3-zipp = "Tim Orling <timothy.t.orling@intel.com>"
diff --git a/meta/recipes-devtools/python/python3-tomli_1.2.1.bb b/meta/recipes-devtools/python/python3-tomli_1.2.1.bb
new file mode 100644
index 0000000000..f62690ff2d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-tomli_1.2.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A lil' TOML parser"
+DESCRIPTION = "Tomli is a Python library for parsing TOML. Tomli is fully \
+compatible with TOML v1.0.0."
+HOMEPAGE = "https://github.com/hukkin/tomli"
+BUGTRACKER = "https://github.com/hukkin/tomli/issues"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "a5b75cb6f3968abb47af1b40c1819dc519ea82bcc065776a866e8d74c5ca9442"
+
+do_configure:prepend() {
+cat > ${S}/setup.py <<-EOF
+from setuptools import setup
+setup(name="tomli", version="${PV}", packages=["tomli"], package_data={"": ["*"]})
+EOF
+}
+
+BBCLASSEXTEND = "native nativesdk"