summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-14 16:49:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-08 17:32:43 +0100
commit8922e609cb947e34cde6e48b82ff37a932d8d8db (patch)
tree2a726fa18a69d25346b3aacbf3b07929d53a2db0
parent4cffb16b0edc353d4a3287ca59ba02640f605d2b (diff)
downloadopenembedded-core-8922e609cb947e34cde6e48b82ff37a932d8d8db.tar.gz
python3-distribute: Upgrade to python3-setuptools 15.2
python3-distribute was merged back to python3-setuptools in 2013, and it is no longer being maintained, this upgrade also provides functionality that will be needed for python3-pip. [YOCTO #7763] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-rw-r--r--meta/classes/setuptools3.bbclass2
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_15.2.bb (renamed from meta/recipes-devtools/python/python3-distribute_0.6.32.bb)40
2 files changed, 23 insertions, 19 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index 40c18c8976..de6dd9440c 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -1,6 +1,6 @@
inherit distutils3
-DEPENDS += "python3-distribute-native"
+DEPENDS += "python3-setuptools-native"
DISTUTILS_INSTALL_ARGS = "--root=${D} \
--prefix=${prefix} \
diff --git a/meta/recipes-devtools/python/python3-distribute_0.6.32.bb b/meta/recipes-devtools/python/python3-setuptools_15.2.bb
index 0ef3a8762f..97058c139c 100644
--- a/meta/recipes-devtools/python/python3-distribute_0.6.32.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_15.2.bb
@@ -1,28 +1,21 @@
SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
-HOMEPAGE = "http://packages.python.org/distribute"
+HOMEPAGE = "http://packages.python.org/setuptools"
SECTION = "devel/python"
LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://setup.py;beginline=234;endline=234;md5=26f6b02022b737126d3c88838782dddb"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
-SRCNAME = "distribute"
-PR = "ml5"
+SRCNAME = "setuptools"
DEPENDS += "python3"
DEPENDS_class-native += "python3-native"
SRC_URI = " \
- http://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
-SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
+SRC_URI[md5sum] = "a9028a9794fc7ae02320d32e2d7e12ee"
+SRC_URI[sha256sum] = "381e78471fb0eff89c4b1a219e8739f48dd87c76ad2d3a790010ca3a62ee29a4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-# http://python-distribute.org/distribute_setup.py
-
-# force the selection of python3
-#PYTHON_BASEVERSION = "3.3"
-#PYTHON_MAJMIN = "3.3"
-
inherit distutils3
DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
@@ -37,15 +30,26 @@ do_install_append() {
rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
- sed -i -e '1s|^#!.*python|#!/usr/bin/env python3|' \
- ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
}
RDEPENDS_${PN} = "\
python3-distutils \
python3-compression \
"
-
-RPROVIDES_${PN} += "python3-setuptools"
-
+RDEPENDS_${PN}_class-target = "\
+ python3-ctypes \
+ python3-distutils \
+ python3-email \
+ python3-importlib \
+ python3-numbers \
+ python3-compression \
+ python3-shell \
+ python3-subprocess \
+ python3-textutils \
+ python3-pkgutil \
+ python3-threading \
+ python3-misc \
+ python3-unittest \
+ python3-xml \
+"
BBCLASSEXTEND = "native"